WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] www. (mysite).com/wp-admin/install.php (29 posts)

  1. Vesajohn
    Member
    Posted 3 years ago #

    Browser not

      picking up

    on the "wp-admin/install.php".
    "No Result".

    Installed and uninstalled the wp-3.1, made the changes to the config/sample/file, and SQL data, + define AUTH keys (8).
    Uploaded the 3.1 using FileZip, upload successfull. 25 files and 3 directories.

    But no joy ? anyone with similar failed experience setting up WordPress?
    But with hind sight / light bulb revelation?
    I would appreciate some advise.

    Thanks.

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try asking your hosts for assistance. This sounds like a server issue.

  3. Vesajohn
    Member
    Posted 3 years ago #

    I sent email to my host yesterday, still waiting for reply.

    The connection to my server went o.k, and the upload also a success.
    As i am waiting for the reply from my host, it could take days? who knows?

    I would like to get the definitions of the following correct, to make sure i understand what goes where (via translation route):

    define('DB_NAME', '');

    /** MySQL database username */
    define('DB_USER', '');

    Q#1. Is the above "My SQL.... username", same as "Database mysql"?

    /** MySQL database password */
    define('DB_PASSWORD', '');

    /** MySQL hostname */
    define('DB_HOST', 'localhost');

    Q#2. Is the "hostname" / local host, possibly the same as the; "server: mysql- ***-**. ?

    If you have useful facts that i can use to identify the error, that would be great and much appreciated.

    Cheers.

  4. Vesajohn
    Member
    Posted 3 years ago #

    Further question regarding the ftp FileZip + changes to the wp-config.php files.

    If make changes to the wp-Config.php on my C:drive folder, and then login to the FileZip, and to my ftp host.

    Can i just over ride the files that i made changes to; FileZip (override) + remote htdoc-wp-config file (override) the changes. Is that the correct procedure? or am i missing something?

  5. Vesajohn
    Member
    Posted 3 years ago #

    Maybe if i lived in the Silicon Valley, then i could expect to get reply from The Local Host on the same day, as when requesting answer/information to a Web Site Setup problem?

  6. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    Could you specify the initial error or provide your domain name?

    define('DB_NAME', ''); - is a database name
    define('DB_USER', ''); - username for your database
    define('DB_PASSWORD', ''); - password for your username
    define('DB_HOST', 'localhost'); - database server name (usually localhost)

    You should see all the database info when creating a new database in your hosting control panel.

    You may change wp-config.php manually on your local computer and upload it to server, or you may run http://your-domain/ and follow the instructions on your screen.

  7. Vesajohn
    Member
    Posted 3 years ago #

    The specific error is;

    WordPress installation won't "install".

    I key in my http://www.nordiccuisinefocus.com/wp-admin/install.php

    And have got reply:

    #1. 404 No Result.
    #2. There doesn't seem to be a wp-config.php file.

    I have made the changes to the wp-config-sample-.
    Including db_data_

    But no joy.

    My host did get back to me. I was asked to upload the wp-3.1 to the htdocs folder. i did just that (removed the directory, and reloaded it all).
    I did notice; that in my wp-config.php.php
    Why does the file have repeat of php.php ?
    Is it because i made a change to the _db_name, and uploaded it, using upload-override?

    Other than that, i have no idea.

  8. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    Try to delete wp-config.php, wp-config.php.php and wp-config-sample.php from the server. Then upload wp-config-sample.php. Then rename wp-config-sample.php on your local computer to wp-config.php and upload to server. Then access http://www.nordiccuisinefocus.com/

    Follow the steps on the screen then.

  9. Vesajohn
    Member
    Posted 3 years ago #

    To Argroup. Thanks for stopping to help, , and for sharing your ideas and knowledge.

    I deleted the wp-config.php file, from the remote server, and the wp-config/sample/.. from my computer.

    Added the SQL data details, and the security password.
    I received a note from my web host, saying that i need to use Ip-address: for the "define (DB_HOST', and not the "local host".

    Q. 1. Is it correct that a database name is the same as the domain name without the .com ?

    define('DB_NAME', ''); - is a database name
    define('DB_USER', ''); - username for your database
    define('DB_PASSWORD', ''); - password for your username
    define('DB_HOST', 'localhost'); - database server name (usually localhost)

    After all that, said and done, the browser still can't find my site? Any other suggestions ?

  10. Vesajohn
    Member
    Posted 3 years ago #

    Ps. I tried to make the changes to the wp-sample.. file on the ftp FileZip server, but it did not allow it. So i made the changes via NotePad off the C:drive on my computer.

  11. arkgroup
    Member
    Posted 3 years ago #

    Forget about wp-sample-config.php, wp-config.php and the most important about editing them with notepad.

    It looks like this installation is a little complicated for you, because you're not familiar with databases.

    Step 1. Delete wordpress from the server.
    Step 2. Download wordpress from wordpress.org
    Step 3. Unzip it on your local computer.
    Step 4. Upload it to server.
    Step 5. Rename wp-sample-config.php to wp-config.php on your local computer
    Step 6. Upload wp-config.php to server
    Step 7. Set write (777) permissions for wp-config.php
    Step 8. Create database, database username, password for your username in your hosting control panel (Could be cPanel, Plesk, H-Sphere, DirectAdmin, ISP Manager or other).
    Step 9. Access your website using http://you-domain.com/. It will redirect you to installation wizard.
    Step 10. Type blog name, email, and database info you got in Step 8. Follow other instructions. WordPress should be installed then.
    Step 11. After installation change permissions of wp-config.php back to 644 (or 444).

    If you'll have more troubles doing those steps, just contact me by email arthur.riskal@arkgroup.org and I'll check it myself, if you want.

  12. Vesajohn
    Member
    Posted 3 years ago #

    Yes, right you are, this has turned out much more complicated than i ever imagined. Also my knowledge of data bases is very limited, i don't even know how limited that is.
    I have a question about the above 1-6 steps.
    Is it really necessary to upload the "sample" to the server first (step 4), followed by the rename (step 5)on my computer.
    Is it not the same as:

    a) download.

    b) expand files.

    c) drag and drop to C: drive.

    d) Open Filezip fpt.

    e) Select C: wordpress folder.

    f) Select the remote host site htdocs, click open.

    f) Shift and down scroll all of the wordpress files.

    g) Drag and drop the files to the remote site: htdocs.

    h) Uploading begins; 25 files and 3 directories.

    I did all that, it should be clean as a whistle.

  13. Vesajohn
    Member
    Posted 3 years ago #

    The from there i go to:

    http:www.www.nordiccuisinefocus.com/wp-admin/install.php

    RESPONSE: from the browser.

    "There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file".

  14. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    First of all, sorry, I made a little mistake about renaming file.
    Actually automatic installation is very simple. I've done it hundreds of times of different versions.

    So, you need to upload all the files and run http://www.nordiccuisinefocus.com/
    You'll be redirected to installation wizard http://www.nordiccuisinefocus.com/wp-admin/install.php

    Now the response you've got. That's normal response from installation wizard. At this point you need to Click on Create Configuration File link. Click Let's go at the second page. Fill in all the database information and click Submit to proceed. You'll need to fill in other information like blog title, username and password for your blog, email. Click next to finish the installation. It should work. If you'll have troubles with database info, wordpress will tell you. If it will not create a wp-config.php file, in this case you may create it manually, but you should insert correct database info there. Concentrate on automatic installation.

  15. Vesajohn
    Member
    Posted 3 years ago #

    I got two steps further, then it stalled again.

    #1. Welcome to WordPress.

    #2. Let's Go!

    After entering the db data, user name, pass word and the host, it went no further. It could not locate the wp-config.php

    I checked the file and made the manual changes.

    Is there specific instruction as "how to", and in "what sequence",the changes need to be made: If the automatic installation is not working?
    e.g. Make no changes to the downloaded wp-3.1file Mysql settings "until"......

    Also at what point does the "Sample" file need to be renamed?

    Because the general instructions seem to rely on the automatic installation.

    Obviously it is not working in this instance.

    Here is one more question, if it makes any sense to anybody?

    The local file list on the FileZip, has changed to reverse order from what it was yesterday? The Admin was up on the top, and the xmlrpc.pfp was last on the bottom. Today the order is in reverse: Xmlrpc.pfp up on the top after the folder.. and the Admin is on the bottom of the 25 files? Does that affect the function of the wp.3.1 file?

  16. Vesajohn
    Member
    Posted 3 years ago #

    Is there someone out there who understands data base and wp-install?

    I have tried the WordPress "5 minute instructions" and the "Detail instructions", but they are not very specific, meaning if the automated install is not working, why not? then what? and what to do? I tried to sort it out by using trial and error. I have got it down to this:

    Deleted all files from the remote host server.

    Deleted files from the FileZip that i had uploaded.

    Deleted all wp.3.1 files from downloads.

    Empty trash bin.

    Ran the Disk clean-up.

    Also made sure the Security/firewall was not effecting the wp-install.

    The download wp.3.1 again. Extract and send to C: drive.

    NEXT STEP.

    This is where the "WP-Install Instructions", seem to be contradictory, and not to the point:

    I am getting two contrary replies from wp, (IF I LEAVE THE WP-CONFIG-SAMPLE), as is (without any changes) after i run the;

    www.(my site...).com/wp-admin/install.php

    "There doesn't seem to be a wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file".

    When i do make changes to the "wp-config-sample" file, then the message from wp-reads;

    “Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation”.

    If you really understand the in's and the out's of "data base", "installs", "FTP" and "remote servers", then maybe this issue is clear as a bell, or a crack in the window, to you, please inform the lesser enlightened one's, and point the way out of a puzzle, please.

    I don't mind reading instructions, but when the instructions are meanderings of information and many possible versions of application, then it turn's into trial and error, one failure followed by another. Like if i was the first person to ever to use the wp.3.1 ? Not very likely.

  17. basslion
    Member
    Posted 3 years ago #

    Yeah this wordpress is being a nightmare to me too. At least you are seeing some screens. All i get is blank screen fromt the get go.

    Check your path (file location). wp-config.php should be in the same folder as the directories wp-admin/, wp-content/ and wp-includes/ (commonly referred to as the WordPress ‘root’ or top-level directory). Verify there is no whitespace in the file

    Download
    wp-config.php
    (if you don’t have shell access).
    Open it in your favorite text editor.
    Check that the first line contains nothing but
    <?php
    , and that there is no text before it (not even whitespace).
    Check that the last line contains nothing but
    ?>
    , and that there is no text after it (not even whitespace).
    Save the file, upload it again.

    I just copied this from various blogs, not sure if it will solve yer issue though as im not having the same issue.

  18. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    Sometimes you just need to start from the very beginning. You've confused yourself, while the installation is very simple process. It's not bad, it's normal, because you probably don't have much experience with websites.

    I can install wordpress for you for free and show you screenshots of every step. I think it will be better for you not just to read instructions, but also to see how to install. By the way, may be there are some videos on youtube exist about installing wordpress.

    So, my email is in my previous post, just contact me and I'll create a little tutorial for you. I'll need to know your domain name, credentials from hosting control panel (to create new clean DB, db username and password) and FTP (to upload wordpress). Don't worry about credentials, you may provide me temporary passwords, or change after I install. I've worked in different hosting companies before, you can trust me.

    basslion,

    I've posted an answer into your thread. It's 99% database related issue (incorrect info in wp-config.php).

  19. Vesajohn
    Member
    Posted 3 years ago #

    Reply to Basslion.
    Thanks for the tip, yes i have made sure that the file package is left alone just as they come from the wp-download.

    The nightmare is that the "Instructions" are so haphazard to read, and for anybody without previous knowledge and experience, following those Instructions is confusing, misleading, distracting and crazy.

    There is the:

    Famous 5 Minute Install.

    And the: Detailed Instructions.

    When i do as the "Famous 5 Minute" instructions, i get to the point 6. The browser replies:

    "Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation".

    That's it right there, the broken link.

    To Arkgroup.

    True, i don't have much experience in building web sites. I disagree that i have "confused my self", no on the contrary, the "Instructions" are confusing, they don't have a single line of thought. It is most likely put together by some 50 heads combined, all contributing some ideas or thoughts/wordings. It is not singular. If i ask a simple question re the installation, i can't get a simple answer. You say it is easy/simple, and the "Famous 5 Minute Install" S.I.M.P.L.E, But there is no singular basic instructions to support the claim.

    For example:

    Take me through the basic steps.
    a). Download, extract the folder files, D&D to the C:
    b). Open the WordPress file.
    c). Rename the wp-config-sample.php file to wp-config.php.
    d). Open wp-config.php in a text editor and fill in your database details as explained in Editing wp-config.php to generate and use your secret key password.
    e). Place the WordPress files in the desired location on your web server:
    f). Run the WordPress installation script by accessing wp-admin/install.php in a web browser.

    Simple.. right...?

    Reply: "Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation".

    By the way, extending good will and willingness to help is great. But allowing access to a personal computer is a "Potential Risk" that i don't want to take. There are no rewards for being foolish, and i have learned that the hard way.
    So to your Arkgroup offer of "Chat-tech", thank's, but no thank's. I don't mean it to be personal.

    I would gladly receive take the "step by step" instructions.

  20. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    That's your choice.

    Reply: "Sorry, I need a wp-config-sample.php file to work from. Please re-upload this file from your WordPress installation".

    Quick fix to this is to upload wp-config-sample.php along with wp-config.php (created from wp-config-sample.php).

  21. Vesajohn
    Member
    Posted 3 years ago #

    "Quick fix to this is to upload wp-config-sample.php along with wp-config.php (created from wp-config-sample.php)".

    O.k, i repeat the above instructions, as i understand it to means. Correct me if i am wrong.

    a). Send a copy of the wp-config-sample file to the c: drive where the wp-config.php file is.

    b). Make no changes to it, just drag and drop it into the wordpress folder C:

    c) Open the FTP FileZip.

    d) Open the WordPress drive along side the Filezip, and drag and drop the wp-config sample file to the FileZip server/upload Queue area (bottom).

    e). Process Queue.

    f). wp-config-sample file is now along side the wp-config.php file.

    Including with the remote host server, two located parallel.

    I did all that, and then went to the browser.

    Reply:

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at ****************. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.

  22. basslion
    Member
    Posted 3 years ago #

    Try this, delete the wp-config-sample.php and the wp-config.php from the server and just re-upload the wp-config-sample.php to the server again.

    You may also want to do a clean install too by deleting all the files from the server, then deleting all files from your computer and re-downloading the package and uploading the files back to the server.

    Dont edit the wp-config-sample.php and just run the url http://www.yourdomain.com/wp-admin and it should go to the database setup.

    Also try editing your htaccess file to include the following only:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>

    # END WordPress

    You can also include the following inside your wp-config.php file once you have setup the database and wordpress has created the wp-config.php file for you in the root directory.

    define('WP_DEBUG', true);

    add it just before the following:

    // ** MySQL settings - You can get this info from your web host ** //

    This will report any errors for you on the install.php page. i just tried it on mine and it game me errors about access being denied to my database.

    See after i solved the issue i was mentioning to you before about blank screen right from the start, i then go the blank screen at install.php.

    Access denied i though to myself, hrmmm. So i double checked my wp-config.php and there it was, my password for my database was missing a character. fixed it and uploaded it back to the server and im running smoothly.

    hope that helps!

    Good luck!

  23. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    Error establishing a database connection

    This is a good error. You are close. Information in wp-config.php is wrong. Make sure you have correct database name, database username and it's password, and correct database server. If you're not sure about this info, contact your hosting support and they will help you.

  24. arkgroup
    Member
    Posted 3 years ago #

    basslion,

    Thanks for the info, but the part about .htaccess it's not correct. WordPress will automatically create htaccess file when you enable permalinks and the htaccess lines you've provided will work only for http://domain.com/wordpress/

  25. Vesajohn
    Member
    Posted 3 years ago #

    "This is a good error.

    "You are close".

    "Information in wp-config.php is wrong".

    O.K. i will try changing the LOG IN DETAILS .Part of the db_mysql:

    e.g. IP. *********** to a Mysql: ********** .

    In case the information given by my host for the:

    define('DB_PASSWORD', ''); - password for your username.

    Is not the IP:************ but rather the Mysql:************

    Tell me if i can make the change siply as:

    a). Open C: wordpress-config.php

    b). Make the change, save the wordpad file.

    c) Open FileZilla, remote host.

    d). Click on the wp-config.php file and upload the changes.

    Would that procedure be technically correct, or would it add something unwanted/distraction?

  26. Vesajohn
    Member
    Posted 3 years ago #

    Sorry slight mistake in the previous entry.

    What i meant to say was:

    In case the information given by my host for the:

    define('DB_HOST', 'localhost'); - database server name (usually localhost).

    Is not the: IP. *********** to a Mysql: ********** .

    But surely they should know whether the correct entry for the (DB Host', localhost'), is. They did tell me that it is not the "local host".

    I was told there is a dedicated server for the Mysql.

    Dedicated server? IP: or the Mysql: ?

  27. Vesajohn
    Member
    Posted 3 years ago #

    I was give two codes:

    IP: *******************.
    Mysql:********************.

    And specifially told over the phone that the DB HOST', is the code-IP:

  28. arkgroup
    Member
    Posted 3 years ago #

    Vesajohn,

    If they told you to use IP or domain instead of localhost, then you should do it. It actually doesn't matter what to use: IP or domain name, because server will resolve domain name to IP anyway.

    That is why I recommend you to use such line:
    define('DB_HOST', 'mysql.server.com');

    Where mysql.server.com is their mysql server's domain name.

    By the way, you can post such information here as domain name, IP address of mysql server or it's domain name. It's absolutely safe.

    All the other parameters should be correct too.
    define('DB_NAME', 'database_name');
    Where database_name is a name of new database for wordpress.

    define('DB_USER', 'mysql_user');
    Where mysql_user is username to your database.

    define('DB_PASSWORD', 'users-password');
    Where users-password is a password of mysql username.

    Usually it's possible to create database, database user and password from hosting control panel (like cPanel, Plesk, H-Sphere, DirectAdmin etc.)

    All this info could be also provided by hosting support.

  29. Vesajohn
    Member
    Posted 3 years ago #

    Finally got going again after getting stuck with the wp-install.php

    Thanks for your time, advise and ideas.
    Cheers.

    P.s. i contacted my web host last Friday (18.3), then again on Monday (21.3). They had gone in and installed the wp.3.1 for me. No idea where the fault was, and not looking for it either.

    Problem solved.

Topic Closed

This topic has been closed to new replies.

About this Topic