WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] The requested URL /login was not found on this server. (19 posts)

  1. Jensjacob24
    Member
    Posted 4 years ago #

    Sorry if i posted this else where didnt see where to start a new topic was but anyway

    I recently tried moving my wordpress to my sites root and I changed the home and blog url to my root then moved everything the home page worked but that was it all the rest of the pages didnt, I know its a permalink problem but i cant even login to change it everytime i go to http://www.sypherav.com/wp-admin/ it says
    "Not Found

    The requested URL /login was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    so i cant login to my dashboard to change anything internally, I checked on myphpadmin to see if the blog url was right and it was, I also tried deleting my .htaccess file, that did nothing, i tried changing the permissions of my .htaccess file, that did nothing. so then i had this idea why not move the wordpress back to where it originally was, so i went into myphpadmin changed the blog url back to http://www.sypherav.com/client (the original wordpress location) again the home page worked just fine, but then when i tried to navigate to other pages or to login i get the same error! can somebody please help me!!! i dont know what to do im guessing it has something to do with the .htaccess file but i wouldnt even know what code to change in there this is how my .htaccess file looks
    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName sypherpro.com
    AuthUserFile /home/sypher/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/sypher/public_html/_vti_pvt/service.grp

    i feel like ive tried everything...

  2. Follow these instructions to recover: http://codex.wordpress.org/Changing_The_Site_URL

  3. Jensjacob24
    Member
    Posted 4 years ago #

    i did do all of that before none of it works! was there one in particular you were referring to? thanks

  4. Your htaccess file shows that Frontpage extensions are installed, so check these instructions to make permalinks work with Frontpage. It involves adding one line to various htaccess files.

    If that doesn't work, try deleting your htaccess and regenerating it from the dashboard, if you can get into the dasboard. Or, use these basic WP rewrite rules in htaccess with nothing else:

    RewriteEngine on
    
    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
  5. Jensjacob24
    Member
    Posted 4 years ago #

    i looked at the instructions and apparently the already had that line of code in each .htaccess file, i cant access my dashboard because the permalinks dont work, unless theres another way to get to the dash board

    also with the .htaccess file is that suppose to be in the root of the site? or where your blog is? i dont remember where it was in the first place because I have moved everything around so many times, im going to try that code you have posted there

  6. Jensjacob24
    Member
    Posted 4 years ago #

    ok so i just tried changing the .htaccess file to the code you have posted above when i kept the file in the site root (wordpress in a different directory) it gave me this error when i tried to go to a page other than the home page

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@sypherav.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    when i put the .htaccess in the same directory it goes back to my original problem with the requested url not found

  7. You already tired adding these two lines to your wp-config.php and it didn't work enough for you to get into the dashboard?

    define('WP_HOME','http://sypherav.com/client/');
    define('WP_SITEURL','http://sypherav.com/client/');
  8. Jensjacob24
    Member
    Posted 4 years ago #

    nope everytime i go to http://www.sypherav.com/client/wp-admin/

    it gives me this error message:
    Not Found

    The requested URL /client/login was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.11 (Unix) mod_ssl/2.2.11 OpenSSL/0.9.8i DAV/2 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at sypherav.com Port 80

  9. OK, just to be clear: what directory is wordpress in now? Root, as in syperav.com, or in syperav.com/client ? If it's back in /client, try these lines again, without the trailing slash:

    define('WP_HOME','http://sypherav.com/client');
    define('WP_SITEURL','http://sypherav.com/client');

    Other than that, I'm kinda stumped....

  10. Jensjacob24
    Member
    Posted 4 years ago #

    yeah i moved the site back to sypherav.com/client,

    yeah still nothing
    thats what i dont get, is there anyway for me to perhaps reinstall wordpress and still be able to keep my posts in that case?

    or would you like to take a look at the site for yourself? see if you see somin that i dont? thanks

  11. Jensjacob24
    Member
    Posted 4 years ago #

  12. Well, the URL is specified in the database, and if you reinstalled WP and imported the same database, you'll still have problems.

  13. Jensjacob24
    Member
    Posted 4 years ago #

    MARK IS MY HERO! turns out I had some stuff from my previous domain name interfering with it, thanks again =)

  14. For other readers of this thread, I had to manually delete the permalinks settings in wp_options in the database to get the site back up, as well as fix broken URLs for pages themselves.

  15. AyohAy
    Member
    Posted 4 years ago #

    Hi Mark - Could you possibly help me out?
    http://wordpress.org/support/topic/323462?replies=11
    I have the same problem with no solution in site.

  16. AyohAy
    Member
    Posted 4 years ago #

    I'm not getting this: Error establishing a database connection and can't login to admin at all. This is just getting worse. Can anyone help out? Any ideas?

  17. AyohAy, that new error usually has to do with wp-config file problem or a hosting problem. The other errors - wrong URLs- need to be fixed in the database, i.e.: Changing_the_URL_directly_in_the_database

  18. cpedraza
    Member
    Posted 4 years ago #

    I'm having virtually the same problem, but with a bit of a complication since I use WP Hive.

    I have four blogs set up through WP Hive. Three of them work fine; the fourth is giving me trouble.

    My default WordPress installation is at http://carlospedraza.net, which redirects to carlospedraza.net/blog. That's the blog that's giving me trouble. When I tried logging into the Dashboard - using the URL http://carlospedraza.net/blog/wp-admin, I got a WordPress message stating the database needed to be upgraded and it could take several minutes. I clicked on the upgrade button and the upgrade was accomplished quickly.

    I tried logging in anew at http://carlospedraza.net/blog/wp-admin. I can see from the URL that a redirect happened because something told the browser to go instead to mydomain.com/wp-admin, and that URL in turn displays a redirect to the URL I entered in the first place, mydomain.com/blog/wp-admin. Weird.

    The browser also displayed this message:

    Not Found

    The requested URL /wp-login.php was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.12 mod_fastcgi/2.4.6 Phusion_Passenger/2.2.5 Server at carlospedraza.net Port 80

    ---
    This is the URL that's displayed in the Address Bar:
    http://carlospedraza.net/wp-login.php?redirect_to=http%3a%2f%2fcarlospedraza.net%2fblog%2fwp-admin%2f

    While this is the URL that I entered: http://carlospedraza.net/blog/wp-admin

    I'm not sure if this is a WP Hive issue or simply a WordPress issue, since this particular blog is the one created initially by my WordPress installation, which is itself a redirect from carlospedraza.net to carlospedraza.net/blog.

    I don't have the two 'define wp_home' and 'define wp_siteURL' parameters in my config.php file but both settings do appear in the database's wp_options file (confirmed with phpMyAdmin). That may be because of WP Hive, so I'm loathe to change the config.php file.

    Also, I changed the permalink_structure option from the default to
    /%year%/%monthnum%/%day%/%postname%/ in the database. I'd read somewhere else about that solving the problem, but it didn't in my case.

    I'd appreciate any advice or assistance.

    Regards,
    /carlos

  19. jfox77
    Member
    Posted 4 years ago #

    Thank you, songdogtech for saving the day! I was locked out of my admin and my htaccess file was corrupt so none of my permalinks were working. I created a fresh htaccess file, with permissions set to 644 and the following code:

    RewriteEngine on
    
    <IfModule mod_rewrite.c>
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    That fixed things so I could get back into my admin and my permalinks were restored.

Topic Closed

This topic has been closed to new replies.

About this Topic