WordPress.org

Ready to get started?Download WordPress

Forums

Sudden You do not have sufficient permissions to access this page error (29 posts)

  1. beanfair
    Member
    Posted 5 years ago #

    I have been using wordpress 2.7 on 6 blogs since early December. Suddenly I am getting a You do not have sufficient permissions to access this page on the plugin install page for one of the six blogs.
    I am logged in as admin.
    This is the only page with this error, I can carry out all other admin functions including upgrades.
    I have tried deleting and reinstalling the entire wp-admin directory but the problem persists.
    I have done a search on You do not have sufficient permissions to access this page but the other posts are after a new upgrade and/or about lack of admin access site wide. I can't find information on access being prohibited on a single page.
    Any ideas?

  2. beanfair
    Member
    Posted 5 years ago #

    I have followed all of the steps outlined in the codex, http://codex.wordpress.org/Login_Trouble. I changed the lines in the files as instructed, repaired the database, and have done fresh installs of the wp-config and wp-login file
    I have tried setting up another user with admin privileges but they still get the You do not have sufficient permissions to access this page error. Its been several weeks now and I still can't seem to find a way to bring back admin privileges on this blog.
    Any assistance is most appreciated!

  3. beanfair
    Member
    Posted 5 years ago #

    I finally was able to remedy the problem by forcing a database upgrade. The force db plugin did not work, I had to do this manually by reseting the db_version in the wp_options table to 8204. I logged out and then back into wp-admin. I clicked the upgrade database button and all admin privileges were restored.

  4. netbloke
    Member
    Posted 5 years ago #

    Can you do a more step by step for this? I believe I have the same issue.

    What is the force db plugin? where can I get it. My searches are not finding it.

  5. netbloke
    Member
    Posted 5 years ago #

    Ah that worked for me too! After much fussing around I worked out what you meant.

    I went to wp-admin/options.php

    Changed the db version to the last (8204)

    It then forced a database upgrade and fixed the problem!

  6. kjetterman
    Member
    Posted 5 years ago #

    Thank God for this post! I had the same issue. I also tried the force_upgrade.php script but it did not work.

    Going into phpmyadmin and fixing wp-admin/options.php and then db_version to 8204 worked for me!!

  7. iceq
    Member
    Posted 5 years ago #

    VERY sadly, it didnt work for me !

    I went through phpmyadmin and changed db_version from 9872 to 8204 and tried to login, and I got message telling that I need to upgrade.

    I upgraded the DB, and tried to login again using my two different admin accounts, but I still get the same insufficient permissions message !!

    I am suffering not having this problem only, but GOd knows what :

    "Crazy admin panel and a blank index" http://wordpress.org/support/topic/244158?replies=4

    http://www.al-rasid.com

  8. noise
    Member
    Posted 5 years ago #

    can't find any db version in admin/options.php

    any idea where it is - can't even find the db version in phpmyadmin

  9. noise
    Member
    Posted 5 years ago #

    found the table and forced the upgrade a couple of times - no go.

    Tried with the default permalinks as well as a custom - no go

    this is a BUG!

  10. dsheetz
    Member
    Posted 5 years ago #

    I too am having this problem. I went into phpmyadmin and changed the db_version back to 8204, then went back to the admin and performed the upgrade, but I still get the

    You do not have sufficient permissions to access this page.

    error. I am at a loss for what to do at this point. @noise what do you mean when you say "tried with the default permalinks as well as a custom"?

  11. Giullo
    Member
    Posted 5 years ago #

    Hi to alls,

    By a week my blog (storiaduepuntozero.freehostia.com) is refusing to access at control panel, wp-admin ecc., and tell me:
    "You do not have sufficient permissions to access this page".

    The blog works for visitors, can view posts and pages ecc.

    After I've read this thread I tried accessing in wp-admin/options.php, WordPress tell me like "you think to be smart?" and refuse to allow access.

    After, tried to change db_version from 9872 to 8204, then login: WP told me "Need a database upgrade", ok, but after nothing changed, same error message about permissions.

    Kjetterman, what about "wp-admin/options.php fixing"? I don't understand...

    Previous attempts, alls failed:

    - Verification of permissions of alls files & folders (755, 644): all was in right place;

    - Delete of .htaccess file;

    - Renaming "plugins" folder: blank screen;

    - Renaming each plugin folder, one by one: nothing happen, but renaming plugin "wp-supercache" result is blank screen.

    What can I do to solve the problem?

  12. senseimichael
    Member
    Posted 5 years ago #

    Sigh, I have the same problem too.

  13. Kermanorsu
    Member
    Posted 5 years ago #

    I have similar problems after moving my blog to a different server.

    The blog works just fine for visitors, but when I'm trying to login as Admin, I get "You do not have sufficient permissions to access this page".

    Updating the database or modifying .htaccess or deleting plugins doesn't help.

  14. cudeso
    Member
    Posted 4 years ago #

    I got one step further.In wp-admin/includes/plugin.php in the function user_can_access_admin_page if you change the lines

    if ( empty( $parent) ) {
                    if ( isset( $_wp_menu_nopriv[$pagenow] ) )

    to

    if ( empty( $parent) ) {
    unset($_wp_menu_nopriv[$pagenow]);
                    if ( isset( $_wp_menu_nopriv[$pagenow] ) )

    then you're able to login ... but you have no permissions to do anything.

    Any help appreciated.

  15. mkaresh
    Member
    Posted 4 years ago #

    In my case the problem was that I had renamed my tables and changed the prefix in wp_config. Apparently I needed to change something else in addition to these things.

  16. mkaresh
    Member
    Posted 4 years ago #

    Okay, found this. The first one would have done it.

    For table wp_new_options
    wp_user_roles becomes wp_new_user_roles

    For table wp_new_usermeta
    wp_capabilities becomes wp_new_capabilities

    wp_user_level becomes wp_new_user_level

    wp_autosave_draft_ids becomes wp_new_autosave_draft_ids

  17. whdr02
    Member
    Posted 4 years ago #

    I am able to log in with my admin account but no other accounts appear to be able to access the admin panel.

    I forced a database upgrade -- No fix.
    I verified that my user meta options all have my database prefix -- No fix

    Any other ideas out there?

  18. frescova
    Member
    Posted 4 years ago #

    Cool; thanks mkaresh - other than those values, do any more need to be updated with the new table prefix?

    As I followed your updates I noticed there were many other fields with the previous "wp_" values - just curious if you updated them to "wp_new" as well...

    Thanks again...

  19. zevy
    Member
    Posted 4 years ago #

    Thanks a lot mkaresh.

    > there were many other fields with the previous
    > "wp_" values - just curious if you updated them
    > to "wp_new" as well...

    Would love to know the answer to this too.

  20. xiannie
    Member
    Posted 4 years ago #

    I did a manual upgrade from 2.0.5 to 2.8.4 carefully following the instructions here http://codex.wordpress.org/Upgrading_WordPress_Extended . When I was done, I also got the 'You do not have sufficient permissions to access this page' message on all wp-admin pages when logging in as admin. Removing the four 'security' keys AUTH_KEY, SECURE_AUTH_KEY, LOGGED_IN_KEY, and NONCE_KEY from wp-config.php was the only thing that allowed me to login. :/

    Anyone have any suggestions on how to keep these security features and still maintain access?

  21. arpeedee
    Member
    Posted 4 years ago #

    xiannie:
    I tried your fix, but unfortunately it didn't work for me.

    There's a link in that section of wp-config you can use that will allow WordPress to generate the four keys for you - you can then copy and paste into wp-config, save and re-upload it.

  22. harry2k
    Member
    Posted 4 years ago #

    @mkaresh, When I changed my domain name, I had to rename all the tables and the enteries within.
    I can access the ADMIN dashboard with all the capabilities. The ONLY thing that I CAN'T still see is "AND NEW" under PLUGINS and APPEARANCE.
    So effectively I can't upgrade any plugins, themes or future upgrades of WP. I can ftp the themes and plugin which works perfect.

    Anybody here with this problem?
    Much appreciate your help.

  23. harry2k
    Member
    Posted 4 years ago #

    ok. changing the db_version from - 11548 to 8204 did the trick. I can now see "Add New" buttons and I can upgrade the plugins, wp to the newer version.

  24. Brooke Dukes
    Member
    Posted 4 years ago #

    I had this issue after I changed the prefix of my wp-table. I found the solution here: http://beconfused.com/2007/08/28/how-to-solve-you-do-not-have-sufficient-permissions-to-access-this-page-in-wordpress/

    Hopefully someone will find that useful.

  25. OlivierM38
    Member
    Posted 4 years ago #

    Hello,

    I had the same issue following an upgrade to 2.8.6... (error message when trying to access the plugin page from plugin edit).

    Changing db-version from 11548 to 8204 and then running the upgrade script did the job.

    Thanks for the tip.

  26. supadigi
    Member
    Posted 4 years ago #

    I have the problem that I cant delete or create pages even though I am logged in as admin.

    I cant find db_version in my opions.php or via phpmyadmin though to do the forced upgrade?

  27. manu595
    Member
    Posted 4 years ago #

    Yeah, there is no db_version in options.php. But if I go via phpmyadmin I could find db_version, but there is no value that I can edit?

  28. sabinevi
    Member
    Posted 4 years ago #

    I had a the same problem with saving some plugin settings. In my case it was a funny server setting that caused the problem: my WP installation is hosted on a Linux server running Apache but the hosting company tries to mislead hackers saying (through a server setting or something like that) that Internet Information Server (IIS) is installed as server software. You can find this information running a phpinfo() or if you don't know how to do that, calling your hosting company.

    In wp-settings.php there are a few lines of code that double the querystring for sites on IIS (don't ask me why) and that is where things go wrong because the website is not actually on IIS but the script thinks it is. I commented out lines 89-91 in wp-settings.php and my problem was solved. Like so:

    // Append the query string if it exists and isn't null
    /*if (isset($_SERVER['QUERY_STRING']) && !empty($_SERVER['QUERY_STRING'])) {
    	$_SERVER['REQUEST_URI'] .= '?' . $_SERVER['QUERY_STRING'];
    }*/

    Hope this helps someone!

  29. Sarah_h
    Member
    Posted 4 years ago #

    Ok I had the same problem as everyone heer and this is what fixed it for me.

    I originally changed the wp_ suffix on localhost to something like this 'fh64Q' and all ok. Now I moved to production server and found I had the no perms as seen here, I could do nothing in admin. The problem, it turned out, was to to with the suffix. An upper case 'Q' in my suffix had changed to lower case 'q'!! I don't know why it changed though. Anyway I did a search and replace in the sql and everything just worked!

    So I hope this helps someone.

Topic Closed

This topic has been closed to new replies.

About this Topic