WordPress.org

Ready to get started?Download WordPress

Forums

WPtouch Mobile Plugin
Safari cannot open page because too many redirects occurred (22 posts)

  1. baweibel
    Member
    Posted 3 years ago #

    My blog is http://holeinthedonut.com. I am getting the above error on my iPhone with WPTouch 1.9.26 whenever I try to access almost any page other than the home page. The home page itself displays but shows only a very few posts (for example only one in May and not another until back in March, yet if I click on rss feed all my posts show up. If I go to the "About" page, or click on any link on the internet that directs to my page (including a Google search), I get the above error. If I click on the tags or categories tabs I do get to a page, but only very few posts show up (for example, for the "around the world" tag I have 142 posts, yet only one shows up. I am running W3 Total Cache and have followed the directions to use it with WPTouch and it was running successfully when I first activated it about a month ago but now seems broken. I've done a search about the "Safari cannot open page because too many redirects occurred" error and found some comments such as: "Have you set WPtouch's homepage? If you've set it to the same one you've defined in WordPress that will happen. That setting is really only if you want to specify a different homepage" however I cannot find any such setting on the current WPTouch settings. It does, however, seem to be going around in an endless redirect loop. Really appreciate any help or suggestions you can offer.

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    It appears that you haven't set your website to force either www or non www. So both
    http://www.holeinthedonut.com and holeinthedonut.com resolve.

    You might want to force it to be one or the other, to collapse your search results and imporve your search rankings, among other things.

    It seems WPtouch is trying to load with http://www.holeinthedonut.com, whereas the desktop theme is trying with holeinthedonut.com.

  3. baweibel
    Member
    Posted 3 years ago #

    Thank you for your response, Brave New Code. In the general settings of WordPress, my WordPress address and site address are shown as http://www.holeinthedonut.com. However, in Google Webmaster Tools I have claimed and verified both the www and non-www vesion of my url and set my preferred domain as holeinthedonut.com. Additionally, I am using the Platinum SEO Pack Plugin and enabled Canonical url's.

    Since I originally asked for support help I have tinkered and finally got it to work correctly again by removing all excluded categories and tags. It appears they were the culprit, as everything reverted back to normal once the tag and category ID fields were left empty.

    I would, however, be very appreciative if you could elaborate about any conflict that might be occurring with the www versus non-www urls, considering the info I have provided above. Thanks in advance.

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    Hmmm— not sure why that would be, with the cats and tags issue. We'll log that o be looked at.

    Sounds like you've got your bases covered on the URL front. We simply use .htaccess to force www on the url.

    http://www.htaccessbasics.com/force-www-nonwww-domain/

  5. burdnick
    Member
    Posted 3 years ago #

    I recently added the wpTouch into my wordpress site and am having a similar issue.

    My .htaccess page reads :

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    # Redirect non-www urls to www
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^66thieves\.com [NC]
    RewriteRule (.*) http://www.66thieves.com/$1 [R=301,L]

    and my wordpress settings say http://www.

    I am still getting this redirect warning for - http://www.66thieves.com

    Please advise.

  6. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    Have you disabled the plugin?

  7. gregmu1
    Member
    Posted 2 years ago #

    Hi, I am having the same error, but I don't have the WPTouch plugin. I only get this error when going to the homepage on my iPhone Safari browser. I can go to any other URL on my iPhone though. It is only my homepage http://www.grapethinking.com that doesn't work.

    Any suggestions?

  8. LHMaintenance
    Member
    Posted 2 years ago #

    I too am seeing the same problem, but am not nearly as tech savvy as everyone here. Is there a page to walk a dummy through this installation? Basically, I installed the plugin, and configured a few tabs for the mobile site and for some reason the "home" page gives me this error message. My site is http://www.lakeshorehomemaintenance.com. Ideas?

    Sarah

  9. gregmu1
    Member
    Posted 2 years ago #

    I don't think installing the plugin helps. I think people got the error because they already had the plugin installed and had a redirect set.

  10. Janellie23
    Member
    Posted 2 years ago #

    Hello, I am also receiving the iPhone safari error message. I do not have the WPTouch plugin. I use a child theme of Twenty Eleven. My site is http://minneapolis81.com/

    Suggestions for troubleshooting?

  11. Janellie23
    Member
    Posted 2 years ago #

    After clearing the history and cookies and data in Safari my WP site loaded just fine.

  12. Mrgrindmode
    Member
    Posted 2 years ago #

    This was a reason this error occurred.

    http://wordpress.org/support/topic/error-too-many-redirects

    The issue was resolved.

  13. gregmu1
    Member
    Posted 2 years ago #

    Thanks Jenellie, I went into Settings on my iPhone and cleared the history and cookies and data and it worked.

  14. sebi8624
    Member
    Posted 2 years ago #

    Dear all, I am facing the same problem with WPTouch: I get the "Safari cannot open page because too many redirects occurred" error message. When someone wants to reach my page, he reaches a frontal server (www) that makes a redirection to a secondary server (www2) and rewrites www2 as www to make it transparent for the user. Then the user reaches my web root directory where he finds .htacess that tells him that wordpress is installed in its own directory. Sounds complex I know, but I cannot do anything about it as my website is hosted by my institution. But it works fine when WPtouch is deactivated. Troubles start when the plugging is activated and I want to reach my page with a smartphone. Any idea that could help? With kind regards. Sébastien. My webpage address: http://www.lirmm.fr/~krut

  15. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hi sebi8624,

    Please make sure that the WPtouch Home Page is not set to the same page as the Static Front page in your WordPress Reading settings to prevent the "too many redirects" issue.

  16. sebi8624
    Member
    Posted 2 years ago #

    Thanks!! It was the answer to my issue. With kind regards, Sébastien

  17. phattrance
    Member
    Posted 2 years ago #

    I have the same problem BUT IM NOT USING WPTOUCH.

    My URL is http://funny-pictures-blog.com/ and im using a plugin to redirect the mobile users to my custom mobile version with the URL: http://funny-pictures-blog.com/m.php

    i have tried several plugins and im getting the same error message with all of them.

    Does anyone know what could be wrong here and how i fix this?

  18. monkeykiddo
    Member
    Posted 2 years ago #

    I also have the same problem with W touch. I have changed my wptouch home page to wordpress settings instead of home. IS this correct? Thanks

  19. terrorfall
    Member
    Posted 2 years ago #

    Same for me. Have tried everything suggested including;

    - Changing .htaccess to force users to non-www domain
    - Changing WordPress>Reading settings to avoid conflict
    - Uninstalling/Reinstalling plugin
    - Clearing all caches and history

    The plugin has worked fine for me for a month, and now it's stopped working. Only thing that has changed about my blog is a WP upgrade to version 3.3.1.

    I also have the Pro version and can't get onto the forums on Brave New Code's website.

  20. dejliglama
    Member
    Posted 2 years ago #

    I'm using the Mobile Device Detect Reloaded plugin with same result. Other forum posts suggests this to be a core problem after 3.2.x .. I'm running 3.2.1.

    I've triede multiple suggested solutions, none working...

  21. archimedia
    Member
    Posted 2 years ago #

    thank Janellie23 that worked for me too.

  22. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    For reference:

    The "too many redirects" issue is usually caused by setting the "WPtouch landing page" to the same page that is set to the Front page in your WordPress > Reading settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags