WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: SI CAPTCHA for WordPress] Error reading captcha cookie (41 posts)

  1. creativefield
    Member
    Posted 5 years ago #

    Whenever I activate Captcha on comments, I receive this error:

    ERROR: Could not read CAPTCHA cookie. Make sure you have cookies enabled.

    Cookies are enabled on both I.E. and Firefox. Any thoughts on what the problem could be?

    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/

  2. jonmrich
    Member
    Posted 5 years ago #

    I'm having the same issue. I tried in Chrome as well.

  3. Mike Challis
    Member
    Posted 5 years ago #

    Cookies have to be enabled in your web browser and not blocked for the blog web domain. In version 1.7, I added the feature to check for the cookie.

    Before version 1.7, a blocked cookie would cause a user to be confused as to why the captcha would always return the error "you entered wrong CAPTCHA". The cookie check prints the error to indicate what might be the actual problem.

    The cookie check is working fine for me, so before I determine that anything is wrong with this feature, please reply with more information:

    Check your web browser settings and make sure you are not blocking cookies for your blog domain. Did you just install this plugin or were you using it prior to version 1.7?

    Can you uninstall version 1.7.x, then manually install version 1.6.9 and test that the CAPTCHA works and that you can post a comment when not logged as admin(type the captcha letters)
    http://downloads.wordpress.org/plugin/si-captcha-for-wordpress.1.6.9.zip

    What was the result of your test of version 1.6.9? Did it work?
    if yes, I have broke something.
    if no, your browser is blocking or you have another plugin that is improperly setting a session before header output (in that case I would like to help you further to determine which one)
    I can tell you that the plugin called "Shopp" is not compatible.

    Your answers to these questions will help me rapidly determine what could be the problem.

    Thanks for helping me help you.

  4. Mike Challis
    Member
    Posted 5 years ago #

    Nobody else has reported this problem, I do not think there is anything wrong with the plugin. So...
    For others who may have this problem and find this post:

    Check your web browser settings and make sure you are not blocking cookies for your blog domain. Cookies have to be enabled in your web browser and not blocked for the blog web domain.

    So either your browser is blocking cookies or you have another plugin that is improperly setting a session cookie before header output (in that case I would like to help you further to determine which one)
    I can tell you that the plugin called "Shopp" is not compatible because it handles sessions differently causing the CAPTCHA error "You entered in the wrong Captcha phrase".

  5. ThecounT
    Member
    Posted 5 years ago #

    same issue..

  6. Mike Challis
    Member
    Posted 5 years ago #

    ThecounT,

    Sorry you are having trouble. I did not hear back from the other two. Can you try the things I suggested?
    Let me know the results.

    Thanks

  7. timmickey
    Member
    Posted 5 years ago #

    Mike,

    Just installed 1.7.6. I'm having the same issue on 2 different WP installs. Yes, cookies definitely enabled. Getting "ERROR: Could not read CAPTCHA cookie. Make sure you have cookies enabled."

    Tried installing 1.6.9 from the zip you linked to. Now, I'm getting this error
    "Error: You entered in the wrong Captcha phrase. Press your browsers back button and try again."
    ( and after like 20 tries in multiple browsers I'm sure I've entered the code correctly at least once )

    Any other suggestions?

  8. Mike Challis
    Member
    Posted 5 years ago #

    timmickey,

    If you have ruled out cookies being blocked... I suspect another plugin is conflicting with the PHP session.
    What other plugins do you have installed?
    Can you temporarily deactivate them one at a time until the conflicting plugin is pinpointed? If a conflicting plugin is found I might be able to fix it. Once the conflict is resolved you can use this plugin 1.7.6 or higher.

  9. Mike Challis
    Member
    Posted 5 years ago #

    == Changelog ==

    = 1.7.7 =
    - (30 Aug 2009) Added a cookie_test.php to help diagnose if a web browser has cookies disabled.

    This cookie_test.php can be used to test if your browser is accepting cookies from your site: Open this URL in your web browser to run the test: (put your blog domain in the first part of the URL)
    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/cookie_test.php

  10. Mike Challis
    Member
    Posted 5 years ago #

    Tim e-mailed me, I hope to do some more testing to find the cause. I will report back here what I find.

  11. Mike Challis
    Member
    Posted 5 years ago #

    I found the problem for Tim,

    His PHP installation had a problem where a session would not start because the session directory was missing or misconfigured permissions.

    The tests in my new update can test for that....
    so if anybody is having a problem with it, they should try these tests.

    = 1.7.9 =
    - (31 Aug 2009) Added more diagnostic test scripts: a Cookie Test, Captcha test, and a PHP Requirements Test.
    Click on the "Test if your PHP installation will support the CAPTCHA" link on the Options page.
    or open this URL in your web browser to run the test:
    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php

  12. creativefield
    Member
    Posted 5 years ago #

    Hi Mike,

    Thanks so much for the diagnosic tests - these are great! I followed your instructions to test if the cookies are enabled (they are) and my PHP installation will support CAPTCHA. I am still receiving the same error message, even after deactivating each plugin one at a time, to see if they were the cause of the problem. I have the latest SI CAPTCHA version 1.7.9. Do you have any other suggestions?

  13. Mike Challis
    Member
    Posted 5 years ago #

    creativefield,

    Please email me your blog URL: 642weather at gmail dot com
    I would like to find out for you what is causing this. Finding out might help me help others also or make the plugin better.

  14. Mike Challis
    Member
    Posted 5 years ago #

    A couple users had this problem:

    If you look on the test page URL, and you see a session error at the top of the page then here is a problem with your PHP installation. It cannot open the session directory. Make a trouble ticket with your web support, give them a copy of this message with the URL to the test page so they can look at the error, they will fix it.

    Test page URL: (add your blog URL before it)
    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php

  15. joannesjacobs
    Member
    Posted 5 years ago #

    I'm having the same error.

    Secureimage PHP Requirements Test
    This script will test your PHP installation to see if (Secureimage) CAPTCHA will run on your server.

    Note: If you see any errors or warnings at the top of the page, especially "Warning: session_start...", they could be indicating a problem with your PHP server that will prevent the CAPTCHA from working.

    PHP Version: 5.1.6
    GD Support: Yes!
    GD Version: bundled (2.0.28 compatible)
    TTF Support (FreeType): Yes!
    JPEG Support: Yes!
    PNG Support: Yes!
    GIF Read Support: Yes!
    GIF Create Support: Yes!
    Since you can see this...

    Try the PHP Requirements Test again
    Try the Cookie Test
    Try the CAPTCHA Test

    PHP Scripts by Mike Challis
    Free PHP Scripts
    Donate, even small amounts are appreciated

    Contact me: (Mike Challis)
    I will need to know this information: (fill in this information on my contact form)
    Plugin: SI CAPTCHA for WordPress
    Plugin Version: 1.7.12
    Your web site URL: http://joannejacobs.net/
    Problem you are having: Same CAPTCHA cookie error.

    POSSIBLE CONFLICT: Better Tag Cloud plugin version 0.6.4.

  16. joannesjacobs
    Member
    Posted 5 years ago #

    PS: Have deactivated SI-Captcha for the present whilst this issue is resolved.

  17. Mike Challis
    Member
    Posted 5 years ago #

    Try all 3 tests on this page.
    /wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php

    Follow the instructions on the test pages. They instruct you as to what could be the problem. I tested on your server and it could be 2 things:
    1) you may have cookies blocking on your web browser for your web page.
    2) you have another plugin conflicting.
    Since you disabled the plugin, I cannot test it completely from my view.

    If all 3 pass, the problem could be another WordPress plugin is conflicting with the PHP session. What other plugins do you have installed? Can you temporarily deactivate them all. Test, now if it works, activate them one at a time (then test) until the conflicting plugin is pinpointed? If a conflicting plugin is found I might be able to fix it (or not), then we can notify the plugin author.

  18. ghbarratt
    Member
    Posted 5 years ago #

    Mike,

    We were having the same problem with the SI Captcha plugin. We are always taken to a page that says "ERROR: Could not read CAPTCHA cookie. Make sure you have cookies enabled and not blocking in your web browser settings. Or another plugin is conflicting. See plugin FAQ.
    "

    The blog I am working with is http://www.mrsfieldssecrets.com/blogs

    I "ran" all three tests at:
    http://www.mrsfieldssecrets.com/blogs/wp-content/plugins/si-captcha-for-wordpress/captcha-secureimage/test/index.php

    and they all claimed they worked fine.

    So here is the most interesting part...
    After I ran the tests, I then went back and tried to enter a comment on the blog and I never got the cookies error again, but I did seem to have a lot of trouble getting the codes in. I mean I know I was entering them in right but I was only getting in like 1 out of three times. (I think this problem might be related to how the servers are set up for this client.)

    Anyways, my boss said to uninstall this plugin because the cookie problem will be more trouble than it is worth and also he did not like the fact that the code input is displayed underneath the submit button and the tab order seemed to be messed up to him.

  19. Mike Challis
    Member
    Posted 5 years ago #

    "also he did not like the fact that the code input is displayed underneath the submit button and the tab order seemed to be messed up to him."

    This in the FAQ. (easy to fix, even a setting in options to fix)
    http://wordpress.org/extend/plugins/si-captcha-for-wordpress/faq/

  20. Mike Challis
    Member
    Posted 5 years ago #

    joannesjacobs got hers working, her theme had the comment_form action hook disabled.

  21. msieurpakal
    Member
    Posted 5 years ago #

    so the problem is solved for me. In the comments.php of my theme i searched the <?php do_action('comment_form', $post->ID); ?> and i found : <?php # do_action('comment_form', $post->ID); ?> !!!! You see what i mean lol. i removed the # and everythings ok.
    Thks MikeChallis for the plugin

  22. theshermans
    Member
    Posted 4 years ago #

    Hi.

    I am getting the same problem on my page.

    I just use the captcha on a register form.

    I checked comments.php and everything looks ok and also the tests work. I've tried going back to 2.1 which didn't work either. 4 users have registerd using the captcha at some point and I haven't been messing around with the theme so I don't understand what has changed. I've had to disable it for now.

  23. manntis
    Member
    Posted 4 years ago #

    I have the same problem. All 3 tests checked out okay. After I ran the tests I could post comments from my machine, but it failed on others. Deactivated plugin until a fix can be found.

  24. Mike Challis
    Member
    Posted 4 years ago #

    manntis,

    Check for other plugins that interfere with the session.
    There are a few plugins that could cause it.
    Temporarily deactivate other plugins to troubleshoot.

    Mike

  25. zelwent
    Member
    Posted 4 years ago #

    Hi Mike --
    I am having this same issue; I'm trying to use this for the comment section.
    I'm using the latest version and have no other plugins on my blog. Cookies are enabled on my web browsers as well.
    I did the cookie test and it said I had a php server error.
    What do you think could be the problem? Is this something I need to talk with my web hosting about or is it something that I need to fix on my own?

    thanks in advance

  26. Mike Challis
    Member
    Posted 4 years ago #

    zelwent,

    PHP sessions are required to set a cookie, or the CAPTCHA will not work.
    This is pretty routine stuff.

    This error is telling you the PHP sessions are broken on your server
    installation because it cannot find or read the session directory. Make
    a trouble ticket with your web host. Send them the error and a URL link
    to the test page. They will fix it.

  27. zelwent
    Member
    Posted 4 years ago #

    Thanks Mike, I'll give it a try and let you know.

  28. zelwent
    Member
    Posted 4 years ago #

    That did it! Thanks Mike!

  29. gbdriver
    Member
    Posted 4 years ago #

    I'm having this problem too using the Fast and Secure Contact Form Version 2.0.1.

    I've run the test script and passed, I've also tried the Cookie Test and the CAPTCHA Test and both those passed too.

    I've tried deactivating all plug-ins without any success.

    The site I have it installed on can be found here.

    Any help with this would be greatly appreciated, thanks, Rob.

  30. Mike Challis
    Member
    Posted 4 years ago #

    Rob,

    Looks like you uninstalled it?

Topic Closed

This topic has been closed to new replies.

About this Topic