WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: mySTAT] Plugin could not be activated because it triggered a fatal error. (22 posts)

  1. Ovidiu
    Member
    Posted 5 years ago #

    nothing appears in my error logs when I get this error.
    using wp 2.8.2 and a hybrid child theme...

    http://wordpress.org/extend/plugins/mystat/

  2. dor
    Member
    Posted 5 years ago #

    Yes, i've got this, too.

    Don't know what happened.

    Deleted mySTAT and quite happy now.

    Next time, may be (tm).

  3. Anonymous
    Unregistered
    Posted 5 years ago #

    You Download and unpack myStat manualy?

  4. Ovidiu
    Member
    Posted 5 years ago #

    no I had installed it via the wordpress Plugins => Add new option.

    I am currently downloading and then manually uploading and installing it to check again.

    Gives the same error. so I deactivated all plugins, then activated mystats and reactivated all other plugins. seems good now, will have to wait for visitors to check though.

  5. Ovidiu
    Member
    Posted 5 years ago #

    nope. after the plugin is active, my back end break. the plugin page is empty :-( had to delete this plugins folder :-(

    It looks so promising, pelase help me out here :-(

  6. Anonymous
    Unregistered
    Posted 5 years ago #

    Please, open in browser http://__YOUR__SITE__/wp-content/plugins/mystat/tester.php and send me to killer[AT]sandbox.net.ua

  7. Ovidiu
    Member
    Posted 4 years ago #

    I have emailed the url to you

  8. Ovidiu
    Member
    Posted 4 years ago #

    any news? I am really keen on using this plugin :-(

  9. Ovidiu
    Member
    Posted 4 years ago #

    anything?

    I have roughly 10 sites I manage and I'd love this plugin. I am on my own root server so whatever it takes, ask me for info, I'd love to figure out the problem, but there is nothing in the log files either :-( at least I haven't seen anything so far.

  10. Anonymous
    Unregistered
    Posted 4 years ago #

    Unfortunately I have no free time, but we will resolve this problem in the near future.

  11. Ovidiu
    Member
    Posted 4 years ago #

    thanks, will wait for a solution

  12. Anonymous
    Unregistered
    Posted 4 years ago #

    Install version 2.3 and activate the option "Log debug information". Then go to "Site Usage" and refresh the main page of your site. Save the file "wp-content/plugins/mystat/data/debug.log" and send it to me killer[AT]sandbox.net.ua. We seek the problem.

  13. Anonymous
    Unregistered
    Posted 4 years ago #

    The option "Log debug information" is activated in the menu "Configuration". Do not forget to disable this option after sending me the file ....

  14. Anonymous
    Unregistered
    Posted 4 years ago #

    If the page with the plugin is not visible, activate and deactivate it and send these files to me.

  15. Ovidiu
    Member
    Posted 4 years ago #

    Ok, there is news now: still getting: Plugin could not be activated because it triggered a fatal error. BUT with more text now:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /var/www/clients/client1/web7/web/wp-content/plugins/mystat/reports/Accept_Languages.class.php on line 44

    Fatal error: Class declarations may not be nested in /var/www/clients/client1/web7/web/wp-content/plugins/mystat/modules/common.class.php on line 2

    I jsut checked my server config: there is no limitation to 32MB!!! all my php limits are way higher than that...

  16. Anonymous
    Unregistered
    Posted 4 years ago #

    change line 28 in file mystat.php:
    from: ini_set("memory_limit","32M");
    to: ini_set("memory_limit","128M");

  17. Ovidiu
    Member
    Posted 4 years ago #

    :-) I deleted that line. plugi nactivated now. you should reconsider that setting. Actually I don't want any plugins playing with my php.ini settings :-(

    will continue testing the plugin now.

    ###edit###
    let me squeeze a feature request and a question in here:

    - would it be possible to include some options like: exclude logged in users or exclude certain wordpress roles from being recorded? OR maybe based on IP? I don't want my (admin) visits to be recorded in the stats.
    - will this plugin record the stats correctly if I am using a caching plugin, i.e. wp suepr cache or won't be cached hits recorded?

  18. Ovidiu
    Member
    Posted 4 years ago #

    ok, not the back end of my blog works perfectly but the front end only displays a blank page.

    error log says:

    PHP Fatal Error: cannot redeclare geoip_load_shared_mem() in ...geoip.inc
    and PHP Fatal Error: call to a member function get Parameter(0 in .... mystat.php

    fixed it by deactivating the "wp slimstat ex" plugin. to be hoenst I'd feel a lot safer if I could run both until I am satisfied I want to exchange the other one with your plugin.

  19. Anonymous
    Unregistered
    Posted 4 years ago #

    The filter will be added in next versions. Problems with caching plug-ins were not observed.

  20. Anonymous
    Unregistered
    Posted 4 years ago #

    I will add check to use of geo data in other plug-ins.

  21. Ovidiu
    Member
    Posted 4 years ago #

    hey that sounds great. to be honest, wp slimstat ex does exactly what I want/need the only missing thing is it doesn't have graphics. you get figures, that is all :-(

  22. pdavisnwa
    Member
    Posted 4 years ago #

    Could it be your PHP version? I received the following error when trying to activate Mystat.

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /*****/****/****/*****/public_html/blog/wp-content/plugins/mystat/modules/common.class.php on line 4

    I did some checking and determined that it was most likely the PHP version that was the cause of the error. I upgraded from PHP 4 to PHP 5 and Mystat activated just fine.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags