WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] page-sitemap.xml : page not found (39 posts)

  1. Hedi
    Member
    Posted 1 year ago #

    Hi,

    I'm using wordpress 3.5.1 and wordpress-seo 1.3.4.4

    On Google webmaster tool I have this message :
    Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.
    This is about page-sitemap.xml I checked the url and I got an error 404 Page not found.
    For now, I disabled the page-sitemap.xml

    I checked others : post-sitemap.xml attachment-sitemap.xml post_tag-sitemap.xml category-sitemap.xml they were all fine.

    Thanks.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Willis08
    Member
    Posted 1 year ago #

    I am also having this problem, except that my post-sitemap shows up blank

  3. rickyprice
    Member
    Posted 1 year ago #

    Same here for my site http://adondeirhoy.com

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    BUT only for the page-sitemap.xml

  4. culture-ist
    Member
    Posted 1 year ago #

    Same issue, however Webmaster Tools is now showing 404 errors for:

    Sitemap: http://www.thecultureist.com/page-sitemap.xml
    HTTP Error: 404
    -

    Sitemap: http://www.thecultureist.com/category-sitemap.xml
    HTTP Error: 404
    -

    Sitemap: http://www.thecultureist.com/post-sitemap.xml
    HTTP Error: 404
    This all just ha[pened last night.

    Yoast, can you please help?

    http://www.thecultureist.com

  5. culture-ist
    Member
    Posted 1 year ago #

    Please disregard - it turns out that it was backupbuddy which caused the errors.

  6. rickyprice
    Member
    Posted 1 year ago #

    In my case the problem continues. I downloaded again and uploaded it through ftp, nothing changed, still get the same error.

  7. cla1121
    Member
    Posted 1 year ago #

    Have always been a fan of the Yoast plugin! But have found this problem also after noticing the error at Google Webmaster Tools.

    Our posts-sitemap (http://www.fluxmagazine.com/index.php/post-sitemap.xml) is empty/blank.

    The others generated at the same time are fine, eg. http://www.fluxmagazine.com/index.php/category-sitemap.xml

    I have tried regenerating by updating a post and doesn't resolve.

    Any support most welcome :)

  8. Hedi
    Member
    Posted 1 year ago #

    1/ The page-sitemap generated is empty... And the plugin redirect to a 404 not found.
    I think one of these may be better when it's empty :
    Not having page-sitemap in sitemap_index (keeps Not found error)
    or
    Having an empty page-sitemap (doesn't seem the best idea ^^')

    2/The page-sitemap generated empty shouldn't be empty.
    For Post and Page : The error occurs when the option "Include in Sitemap" is to "Auto detect", instead "Always include" should work.

    "Auto detect" works if in the advanced settings you have "Meta Robots Index" to "Default for Post type, currently : Index"

    If you have "Index" it doesn't work.
    Seems like it's in the file inc/class-sitemaps.php : what seems to work is changing the line 326
    from
    if ( wpseo_get_value( 'meta-robots-noindex', $p->ID ) && wpseo_get_value( 'sitemap-include', $p->ID ) != 'always' )
    to
    if ( wpseo_get_value( 'meta-robots-noindex', $p->ID ) == 1 && wpseo_get_value( 'sitemap-include', $p->ID ) != 'always' )

    Seems like 1 is NoIndex, 2 is Index and empty is default.

  9. mukie
    Member
    Posted 1 year ago #

    Same issue here for about a 6-10 websites. Please advise on this thx!

  10. solarheatengines
    Member
    Posted 1 year ago #

    I'm also getting the "404 error page not" found when I click on the xml sitemap link. I'm wondering if it could be related to using Google's pagespeed service.

    http://www.solarheatengines.com
    http://www.solarheatengines.com/sitemap_index.xml
    wp 3.5.1

  11. rickyprice
    Member
    Posted 1 year ago #

    I increased the server timeout that is currently working, thou it is not the best option.

    Hedi, I could not find the Include in Sitemap" is to "Auto detect", instead "Always include" part in the plugin, maybe too tired right now. Will search further later on.

  12. psidwell
    Member
    Posted 1 year ago #

    I'm interested in a solution. Yoast WordPress SEO was highly recommended, and it seems to have some usability to it that many others do not.

    Closely following...

  13. moorebd
    Member
    Posted 1 year ago #

    Same problem. Please respond Yoast. Thanks.

  14. Hedi
    Member
    Posted 1 year ago #

    I have updated to wordpress-seo 1.4.1 but nothing changed, the problem remains :/

  15. sofitrends
    Member
    Posted 1 year ago #

    Same error no sitemaps. Thanks.

    Not Found

    The requested URL /handbags/sitemap_index.xml was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at http://www.sofismart.com Port 80`

  16. moorebd
    Member
    Posted 1 year ago #

    Crickets...crickets...about to change SEO plugins if we don't get any support here.

  17. Mr Eddy
    Member
    Posted 1 year ago #

    I have the same problem, but noticed after a while taht it was indexing correctly. BUT in the meantime I had deactivate XML Sitemap function of WordPress SEO.
    Anyway, I compared to what I was getting using Google XML Sitemaps. Google is indexing every page/post proposed this way much quicker !

    All what's missing are the images. I don't know how much this can be helpful, since Google indexed 53 of 155 and I can't check which one are those 53 images...

  18. sofitrends
    Member
    Posted 1 year ago #

    Solved! Today my sitemap is working! I don't know how or how many

  19. Mr Eddy
    Member
    Posted 1 year ago #

    No more errors in Webmaster tools ?

  20. inblues
    Member
    Posted 1 year ago #

    I'm facing the same problem for my site http://www.invoicingsoftware.biz

    http://www.invoicingsoftware.biz/page-sitemap.xml page not found.

    Please help. I'm running WordPress 3.5.1 and WordPress SEO 1.4.4

  21. Mr Eddy
    Member
    Posted 1 year ago #

    Google XML Sitemap works if you want to have some sitemap while waiting for this plugin to be fixed. I didn't find any better solution :/

  22. rickyprice
    Member
    Posted 1 year ago #

    It started working fine and again on 4/2 started giving me the 500!! Hope Yoast looks into this immediately

  23. ali.chakery
    Member
    Posted 1 year ago #

    I have the same issue ... Its weird ... support please ...

  24. rickyprice
    Member
    Posted 1 year ago #

    No news on this yet?

    I keep getting this error on /page-sitemap.xml for my site http://adondeirhoy.com

    Network unreachable: Network unreachable
    HTTP Error: 500

  25. mikeotgaar
    Member
    Posted 1 year ago #

    @Rickyprice
    Looks like you have "Google Sitemap Generator Plugin for WordPress" by Arne Brachhold installed and active (Great plugin and best option for W3TC preload function)
    That's probably the reason for your server returning the 500 internal error message
    Delete the other plugin or off the Yoast plugin sitemap option - Should fix the problem

  26. kimkimg0513
    Member
    Posted 1 year ago #

    This is what I have got:
    The button in the plugin directs me to:
    mysite.com/index.php/sitemap_index.xml
    However the xml file can be found in
    mysite.com/sitemap_index.xml

    same issue for page sitemap

  27. webriot
    Member
    Posted 1 year ago #

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix

    I put that in my .htacess and everything started to work fine.

    Found this solution from this thread:
    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-xml-sitemap-missing

  28. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    @webriots solution above might work for people that have issues, if not, please open a separate thread describing your issue.

  29. rickyprice
    Member
    Posted 1 year ago #

    did not work will create separate thread

  30. pbsbluejay
    Member
    Posted 1 year ago #

    I was having the same problem... sitemap_index.xml 404 Page not found error inside the Yoast WordPress SEO plugin.

    To correct the issue...

    1. Go to WordPress Dashboard >> SEO >> XML Sitemap

    2. Uncheck the "Check this box to enable XML sitemap functionality" box

    3. Click "Save Settings"

    4. Check the "Check this box to enable XML sitemap functionality" box gain

    5. Click "Save Settings"

    6. Click the "You can find your XML Sitemap here:" button. Hopefully, your sitemap will appear in a new tab without the 404 page not found error

    Seems like you have to reset the XML Sitemap. Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.