WordPress.org

Ready to get started?Download WordPress

Forums

124

W3 Total Cache
[resolved] [closed] Page Cache URL rewriting is not working (119 posts)

  1. polle001
    Member
    Posted 2 years ago #

    hi, I just update to Versión 0.9.2 of W3 Total Cache and get this error in the dashboard.

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I had no error before the update, can someone please help in how to fix it ?

    Thanks.

  2. polle001
    Member
    Posted 2 years ago #

    Ok, I have a no style site now.

    Activity in Safari gives me this:

    site.com/wp-content/w3tc/min/02d06687693f209fafefe866efbb4edf.159000699.js
    site.com/wp-content/w3tc/min/17283efd34ed1aeabf37a0b36c1d8664.701589642.css

    Forbidden in both.

    it seems they can't be loaded no idea why. This happens just after updating.

    What to do ?

    Thanks.

  3. Chris Wiegman
    Member
    Posted 2 years ago #

    You probably have two stylesheets with the same name. Check how they're loaded in the functions.php of your theme and make sure there are no duplicate names. If that isn't it a plugin may be overwriting one of your stylesheets.

  4. polle001
    Member
    Posted 2 years ago #

    This happens with Versión 0.9.2 of W3 Total Cache.

    Deactivating it everything works fine, just update and this happened.

    Any fix for this ?

  5. polle001
    Member
    Posted 2 years ago #

    It seems its Minify causing the problem, lets hope Frederick can confirm this.

    If someone else knows a fix, please share.

    Thanks.

  6. Confirmed the same problem.

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    I can 'fix' it by turning off CSS minification.

    Also I did update my min/.htaccess file to:

    # BEGIN W3TC Minify core
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /wp-content/w3tc-ipstenu.org/min/
        RewriteRule ^w3tc_rewrite_test$ index.php?w3tc_rewrite_test=1 [L]
        RewriteRule (.*) index.php?file=$1 [L]
    </IfModule>
    # END W3TC Minify core

    It used to be

    # BEGIN W3TC Minify
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /wp-content/w3tc-ipstenu.org/min/
        RewriteRule ^([a-f0-9]+)\/(.+)\.(include(\-(footer|body))?(-nb)?)\.[0-9]+\.(css|js)$ index.php?tt=$1&gg=$2&g=$3&t=$7 [L]
    </IfModule>
    # END W3TC Minify
    ~

    ChrisWiegman - It's entirely possible I DO have two style.css, since I'm using a child theme.

  7. iwebsource
    Member
    Posted 2 years ago #

    I can confirm that it is not directly caused by the W3TC Minify feature.

    I have W3TC Minify disabled and I am also getting the same error. :(

    Hopefully someone finds a fix for this soon.

  8. iwebsource - What do you have Minify Cache Method: and Page Cache Method: set to?

    I have Minify set to APC and Page set to Disk (Enhanced).

  9. war59312
    Member
    Posted 2 years ago #

    Same here after upgrading to version 0.9.2.

    Looks like a bug in new version. Previous build had no such issue.

  10. icarenow
    Member
    Posted 2 years ago #

    Just an FYI re: the "help" button in Minify settings [(page=w3tc_faq#q41) i.e., "Help" tool available on the minify settings page"] page which lists file-path/file-names that could be manually selected for "minification" ... you can find it under settings:
    "General"->"Minify"->"Minify Mode"->choose "Manual"

    Then when "help" button is clicked, a transparent page opens which appears overlayed on top of the "settings" page -- hard to see. Also can't scroll down on the opened page to select manually the files for minification.

    0.9.2 looks great overall!

  11. ruibo
    Member
    Posted 2 years ago #

    I got the same error as well, but otherwise, everything does seem to be loading fine.

  12. luxboy
    Member
    Posted 2 years ago #

    i also got 3 error after update to 0.9.2!!
    you can see my erros on: http://i51.tinypic.com/aelb1x.jpg

    they are:
    1. The permalink structure
    2. Page Cache URL rewriting is not working
    3. Minify URL rewriting is not working

    i don't no how to fix that problems. i just want to go back to the previous version but i don't no how to do that.

    now, my site still error (because i deleted this plugin) :(

  13. plaban
    Member
    Posted 2 years ago #

    I've theme problem with latest version of W3 Total Cache.Any way to fix it?Currently Ive disabled this plugin.

  14. vitalichka
    Member
    Posted 2 years ago #

    Seems like I am having similar problems with:

    Page Cache URL and Minify URL rewriting.
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    and It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Looking forward to resolving this.

    Also if using a shared host, should we disable database caching and use object caching instead?

    Thank you.

    Salt Lake Examiner

  15. AngieP
    Member
    Posted 2 years ago #

    Dear Frederick,

    I'm sure you can shed some light on this. I have a similar issue as my comment predecessors:

    ++++++++++++++++++++

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    ++++++++++++++++++++
    The .htaccess is writeable.

    I'm sure there are many benefits contained in this new release of your incredible plugin. Can't wait to see it in full-blown action!

    Thanks in advance,
    Angie

  16. vitalichka
    Member
    Posted 2 years ago #

    @AngieP

    Make sure .htaccess is set to 777 then try to auto-install, if does not work add the code manually. So make sure to copy the code before doing auto-install. This should fix autominify. But as far as Page Cache URL rewriting, I still can't figure out how to make it work.

    It's also not talking to CloudFlare using the correct API key.

    Any suggestions? Anyone?

    Thanks

    PS. Oh yeah, almost forgot, make sure to set .htaccess back to 644

  17. vitalichka
    Member
    Posted 2 years ago #

    Maybe this will help.
    I see that it has helped some people.
    Going to try it myself and will let you know.

    How to install W3TC

  18. vitalichka
    Member
    Posted 2 years ago #

    That link has not helped.

  19. vitalichka
    Member
    Posted 2 years ago #

    This seems to have helped.
    I deleted my .htaccess file, created a new empty one.
    Set it to 777 and auto-added all necessary code.
    Also need to add the code here
    Now all I have left is this
    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Haven't figured out how to make this work since everything looks to be set right. I am a bit concerned though, since I think that once I set permissions for .htaccess back to 644 I'm going to probably start seeing the same error messages.

    Hoping someone has a solution.

    Thank you all for your hard work.

  20. vitalichka
    Member
    Posted 2 years ago #

    Yup. Looks like as soon as I attempted to deploy I began to see the same errors.

    #1.

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    #2

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    Sorry for so many posts, I am working on this and really wanting to be helpful.

    Thanks

  21. vitalichka
    Member
    Posted 2 years ago #

    Alright looks like so far the only way to make things work has been to:

    Set page cache under general to basic and not enhanced but it does make everything load much faster than when it was set to enhanced (backend)

    And finally, had to disable URL structure rewriting so now it sets GET variables.

    Had to purge the cache, seems like front end is loading very very slowly now but backend is much faster than under enhanced.

    Seems to work, will look for further updates from you guys.

    Thanks

  22. AngieP
    Member
    Posted 2 years ago #

    @ vitalichka:

    Thank you for your input.
    Disabling "Rewrite URL structure" gets rid of the error warning, but scrambles the theme...

    Angie

  23. simbian
    Member
    Posted 2 years ago #

    same problem here with this latest 0.9.2 version.
    I tried in all ways, make a clean new install, reset .htaccess file, checking permissions, reset plugin settings (i keep them to all default values), empty all caches...

    but when i deploy settings the web site seems scrambled like not applying css!

    I have noticed that this happens just if im not logged as administrator, if i visit the website logged as administrator both preview and deploy settings all working fine.

    I have the same error messages:

    It appears Page Cache URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    It appears Minify URL rewriting is not working. If using apache, verify that the server configuration allows .htaccess or if using nginx verify all configuration files are included in the configuration.

    by now i keep the plugin disabled until a fix is done!

  24. newwws
    Member
    Posted 2 years ago #

    After updating to 0.9.2 I noticed that /w3tc-[domain]/min/.htaccess and /w3tc-[domain]/pgcache/.htaccess contained the rules of both the old and the new version. The rewrite rules of the new version are simply appended to the old rules.

    After fixing that I still got 500 errors when I tried to open any of the w3 total cache setting pages. To fix this problem I had to delete the settings file w3-total-cache-config-[domain].php

    To mimic the situation of a clean install I also removed the W3TC info from the root .htaccess file.

    After that W3TC was running in basic mode.

    The 500 errors reoccurred when I tried to modify the root .htaccess file to add rules for disk caching. The only way to solve that problem was by commenting out the last rewrite rule of the W3TC Page Cache core:

    # RewriteRule .* "/wp-content/w3tc-%{ENV:W3TC_DOMAIN}/pgcache/%{REQUEST_URI}/_index%{ENV:W3TC_UA}%{ENV:W3TC_REF}%{ENV:W3TC_SSL}.html%{ENV:W3TC_ENC}" [L]

    That disables the page cache, so it is not a real solution.

    It seems this version has some serious bugs, which is a pity because there are some really nice new features in this version.

  25. Tracey
    Member
    Posted 2 years ago #

    Just piping up to say: same problem here. I'm using a Genesis child theme as well... not sure if that has anything to do with it.

    I disabled "rewrite URL structure" under the 'Minify', and that killed the error. I'm not sure how much this will impact the caching, but as a temporary fix - until the plugin is fixed - it seems to be working.

  26. Tracey
    Member
    Posted 2 years ago #

    Update: I have had to turn off minify completely, as it was keeping the site templates from working - the site would come up as it would basically without a stylesheet.

  27. jibby38
    Member
    Posted 2 years ago #

    I got rid of W3 Total Cache altogether and got "Quick Cache" instead. My host said my site is running MUCH faster now.

  28. robnalexpress
    Member
    Posted 2 years ago #

    Just upgraded to 0.9.2 and got NO THEME CSS on both sites. Under General Settings - Minify - Minify Mode, I switched to manual and it fixed it for me. Will be watching for a permanent fix.

  29. solRenegade
    Member
    Posted 2 years ago #

    I've found a way to stop the error. First, go to Minify page settings. Then uncheck the "Rewrite URL structure" box. I don't know whether it fix or not but the error stop showing.

  30. polle001
    Member
    Posted 2 years ago #

    Heres a quick fix for all in the same boat.

    In General Settings.
    - Page Cache (Disk Basic)
    - Minify (Manual)

    That will fix the problem mentioned in the first and second post of this thread.

    Another bug is the lightbox windows for some settings (try wizard in minify settings), those don't have a background and become useless, so wait for an update that fix the bug.

124

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic