WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Media Library won't upload images (16 posts)

  1. LukeShavak
    Member
    Posted 5 years ago #

    HELP 'CAUSE THIS IS DRIVING ME NUTTY!!

    Hi.

    Whenever I try to upload an image into my media library, it comes up blank and the file has seemed to upload, however the image won't display within the media library, or on the blog.

    Any suggestions out there in WordPress forum land??

    Thanks,

    Luke

  2. jkovis
    Member
    Posted 5 years ago #

    Are there any warnings or error messages that display when this happens?

    Is it possible to check your server's error logs?

  3. LukeShavak
    Member
    Posted 5 years ago #

    No, no warnings or errors.

    I don't know how to check my server's error logs??

  4. jkovis
    Member
    Posted 5 years ago #

    A couple ideas:

    - Browse your site's directories via FTP and see if the images are actually being uploaded or not
    - Ask your hosting provider to send your site's error logs to you
    - Backup your database and uploads directory (it might be easiest to do a clean install)

    Whenever I try to upload an image into my media library, it comes
    up blank and the file has seemed to upload

    - Take a screenshot of this and upload it so we can better see what's happening

  5. alism
    Member
    Posted 5 years ago #

    Have you doubled checked the settings on this page are correct?
    Admin > Settings > Miscellaneous

  6. jkovis
    Member
    Posted 5 years ago #

    I just remembered reading this sticky post yesterday. I'd make sure you check #4 and #6.

    3. Update your Adobe Flash to the latest version (esp you Linux users!). NOTE: If you update to Flash 10, then you must be running WordPress 2.7 or above. The new Flash version 10 is incompatible with older versions of WordPress.

    6. mod_security might be causing problems. Disable it to see if that is the problem. To do this, make an .htaccess file in your wp-admin directory. Add this to it:

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>
  7. LukeShavak
    Member
    Posted 5 years ago #

    OK guys..

    I checked my FTP client and it appears the files are uploading and are there.

    I checked Admin>Settings>Miscellaneous and the path there seems to be fine. (It automatically creates folders depending on the year, and gives it a folder number)

    I have WordPress 2.8.5 and I'm using Flash 10.

    My plugins did need updating, so I upgraded them, however I attempted to again upload some jpegs and they unfortunately didn't work.

    I tried the mod_security thing. However, when I created the .htaccess text file in the wp-admin for some reason it wouldn't show up within the file?? Therefore, I couldn't add the code....

    Thanks guys, I appreciate your help.

  8. jkovis
    Member
    Posted 5 years ago #

    I tried the mod_security thing. However, when I created the .htaccess text file in
    the wp-admin for some reason it wouldn't show up within the file?? Therefore, I
    couldn't add the code....

    Files with a dot in front of them are usually hidden files so make sure your FTP program is set to display them.

    Also, WP might have created an .htaccess file automatically for you if you turned on fancy permalinks.

  9. LukeShavak
    Member
    Posted 5 years ago #

    I added the mod_security code and pictures are still not working... They do appear to be uploading however.

    Alism you said:
    Have you doubled checked the settings on this page are correct?
    Admin > Settings > Miscellaneous

    I recently changed my hosting provider and had all these dramas when changing over. My username appear to be the same though. I was just wondering if you guys could think if the changing of hosts had anything to do with it?

    Also - how do I do a screendump here in the forum - so I can show you what WP looks like when the picture won't upload.

  10. LukeShavak
    Member
    Posted 5 years ago #

    Oops my mistake. I added the mod security code to the wrong .htaccess file.

    I added below to the .htaccess file in the wpadmin folder:

    # BEGIN WordPress

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    # END WordPress

    Is this correct? Should I have added the #BEGIN and #END because it's still not working? It didn't work either way...

  11. LukeShavak
    Member
    Posted 5 years ago #

    Can you guys think of anything else. Like I was saying the only other thing I can imagine it might be when I changed hosting providers?...

    Thanks fellas.

  12. LukeShavak
    Member
    Posted 5 years ago #

    I worked it out.

    All I had to do was change the upload folder directory to the default setting which is under Settings Miscellaneous option on the dashboard.

    HOORAH!

  13. andrewbacon
    Member
    Posted 4 years ago #

    I'm having the same issue, checked the default file path, tried the security settings in .htaccess, added another .htaccess to wp-admin and no love.

    Please, if anyone has more info, let me know.

  14. nosillacast
    Member
    Posted 4 years ago #

    I'm with Andrew - stuck with no images showing using the image upload button. File permissions on uploads folder on down are set to 777, did the .htaccess dance described above.

    first noticed this when Headway Themes Image Gallery wouldn't work so testing plain WordPress image upload and having it fail proved it wasn't my theme...or did it?

    [ Signature moderated. ]

  15. nosillacast
    Member
    Posted 4 years ago #

    and sometimes you have to type in here for the answer to come to you - I changed my theme to something else and the image shows up. So now on to figure out what's wrong with my theme. hope you find an answer Andrew.

    [ Signature moderated. ]

  16. verdugo
    Member
    Posted 4 years ago #

    Good for you, Luke! I had this same issue, and your fix worked for me! My issue was probably moving my site from the subdomain. Thanks for your perseverence, the results are spreading virally!

Topic Closed

This topic has been closed to new replies.

About this Topic