WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
Link your Facebook account to your WordPress-not enabling? (80 posts)

  1. joymccambridge
    Member
    Posted 2 years ago #

    I have been trying to set up the social publisher, but when I click Link your Facebook account to your WordPress account to enable it isnt..um.. enabling :)
    The facebook window open, but it doesn't complete the action
    Any help would be appreciated.

    http://wordpress.org/extend/plugins/facebook/

  2. AUDIOMIND
    Member
    Posted 2 years ago #

    Same here. "Facebook social publishing is enabled. Link your Facebook account to your WordPress account to get full functionality, including adding new Posts to your Timeline." But when I click on the italicized section it does nothing and goes nowhere.

  3. ustyne
    Member
    Posted 2 years ago #

    I share the same issue with you. When I click on the Link your Facebook account to your WordPress account it gives me a

    An error occurred with Lalibela Ethiopian Restaurant. Please try again later.
    API Error Code: 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    I have doule checked avery aspect of the configuration and all seems very fine I don't know why it will not work.

  4. davidchevalier
    Member
    Posted 2 years ago #

    +1 !

  5. scottlin
    Member
    Posted 2 years ago #

    +2! (I'm glad I only deactivated my third party facebook / wp plugin)

  6. dnoe
    Member
    Posted 2 years ago #

    @ustyne

    That's because you don't have your facebook app configured properly. It tell's you exactly whats wrong in the error.

  7. ustyne
    Member
    Posted 2 years ago #

    @dnoe I used the default URL on the application if not that what should it be? Thanks in advance for your help.

  8. Facebook
    Member
    Plugin Author

    Posted 2 years ago #

    Please post your app id, app namespace, app domain, and site URL so that we can help you debug.

    **DO NOT POST YOUR APP SECRET**

    Thanks

  9. dnoe
    Member
    Posted 2 years ago #

    @ustyne

    It should be the URL of your domain.

  10. dnoe
    Member
    Posted 2 years ago #

    @facebook

    app id: 379375268790531
    app namespace: dales-blog
    app domain: dalenoe.com

  11. scottlin
    Member
    Posted 2 years ago #

    yea i got it sorted.....stupid copy /paste error.....so i had it correct, just a letter was wrong

    so under where it says "Select how your app integrates with Facebook" put the URL with the http part into the section "Website with Facebook Login"

    and it should work no problem from there

  12. joymccambridge
    Member
    Posted 2 years ago #

    Ya...not getting errors on my end..It just isn't doing anything :)

  13. nida78
    Member
    Posted 2 years ago #

    There is an error in the JavaScript shell but only showing for some seconds:

    Unsafe JavaScript attempt to access frame with URL
    
    https://www.facebook.com/dialog/oauth?access_token=[TOKEN]&api_key=[API-KEY]&app_id=[API-ID]&client_id=[CLIENT-ID]&display=popup&domain=n1da.net&locale=de_DE&origin=1&redirect_uri=http%3A%2F%2Fstatic.ak.facebook.com%2Fconnect%2Fxd_arbiter.php%3Fversion%3D8%23cb%3Df1682e527c%26origin%3Dhttp%253A%252F%252Fn1da.net%252Ff18c9b60f8%26domain%3Dn1da.net%26relation%3Dopener%26frame%3Df373724944&response_type=token%2Csigned_request&scope=manage_pages%2C%20publish_actions%2C%20publish_stream&sdk=joey
    
    from frame with URL
    
    http://n1da.net/wordpress/wp-admin/admin.php?page=facebook-settings&fb_extended_token=1&settings-updated=true.
    
    Domains, protocols and ports must match.

    I got same result for Chrome and Firefox :(

  14. silentbeauty
    Member
    Posted 2 years ago #

    @facebook

    app id: 166671596167
    app namespace: americanmominengland
    app domain: americanmominengland.com
    site url: http://americanmominengland.com

  15. AUDIOMIND
    Member
    Posted 2 years ago #

    App ID: 156614641058850
    App namespace: audiomindwebsite
    App domain: http://www.audiomind.us

    Same issue as joymccambridge.

  16. rosshero
    Member
    Posted 2 years ago #

    I've installed the plug-in, set-up the app on the Developer's page in Facebook and I'm getting the following error message when I log in to WordPress:

    Facebook social publishing is enabled. Link your Facebook account to your WordPress account to get full functionality, including adding new Posts to your Timeline.

    The "Link your Facebook account..." is a hyperlink but when I click on it, it doesn't do anything.

    Please help!

  17. mcnesium
    Member
    Posted 2 years ago #

    same here (wp 3.4 fresh installation)

  18. mcnesium
    Member
    Posted 2 years ago #

    ok i got the 'Link your Facebook account...' message away with using firefox 13 instead of chromium 21. it might have been a beta-browser issue, so nevermind that.
    anyway, the next point after Authenticate with Facebook in the WordPress control panel (you will see a status message at the top, asking you to do so). is Publish a post or page to your WordPress site. You should see the post on your Timeline. You can delete the blog post. so i did this, but nothing appears on my timeline. whats the problem now? after i publish a page and go back into the facebook for wordpress control panel, the checkmark at "Publish to author's Timeline [?]" is gone. so i again set it (the popup with the instructions appear), save the changes, write a post, publish it, it appears on my wordpress blog, it does not appear on my facebook timeline, and going back to the control panel, the checkmark again is gone. what's up with this?

  19. dramatwebmaster
    Member
    Posted 2 years ago #

    @facebook I, too, am having the same issue with not being able to add new posts to timeline

    app id: 428618767178688
    app namespace: ucc-dramat-blog
    app domain: uccdramat.com
    site url: http://www.news.uccdramat.com

  20. patv
    Member
    Posted 2 years ago #

    I've quickly run through the code, and this is what i've found:
    The link is calling a javscript that's to open facebook authentication. Unfortunately, there's an error earlier in the code that is preventing the FB object from loading. I've updated my wordpress to 3.4 and got this working.

    I would strongly urge everyone to push their WordPress to 3.4, as this will resolve alot of the issues.

  21. patv
    Member
    Posted 2 years ago #

    As for the 191 error when authenticating your Facebook account:

    You need to specify the app domain and enabled the option 'Website with Facebook Login' with your website URL/domain.

  22. mcnesium
    Member
    Posted 2 years ago #

    like this, you're saying? http://i.imgur.com/iTi2V.png
    i did set all this up in the first place before even trying to post to my wordpress. and i do have a fresh installation of v3.4 as said before.

    i dont know whats wrong but using stable chromium 19 i even get php-errors that do not occure in firefox 13: http://pastie.org/4115357

  23. patv
    Member
    Posted 2 years ago #

    Those aren't PHP errors, they're warnings so i suspect some browsers will throw them while some others will hide them - I believe they're being thrown for everyone so it shouldn't be blocking any code execution.

    As far as the link disappearing, I can't see that being affected by the browsers since it's a check in PHP. If you don't see the link and you see a dropdown with your fan pages (under Social Publisher > Publish to fan page) instead, then it's a Facebook Authentication problem you have, so I can't help you there.

  24. mcnesium
    Member
    Posted 2 years ago #

    yes, i do see the fan pages in the dropdown you pointed at. i also see my facebook friends being suggested in the mention facebook friends area at the post screen. so it does have a connection to my account. it just wont post, as it keeps forgetting the checkmark at Publish to author's Timeline, i guess.

  25. patv
    Member
    Posted 2 years ago #

    From your image, maybe include the www in your login address, but that's that most I can suggest. Start a new thread that is more specific to your problem, since it's out of the scope of this thread's problem.

  26. dnoe
    Member
    Posted 2 years ago #

    Facebook has already said (in a different thread), that this plugin is buggy. They are supposed to be releasing an update this week. Untill then, good luck getting it to work.

  27. kuperus
    Member
    Posted 2 years ago #

    App ID: 381405025255934
    App namespace: athousandmonkeys
    App domain: http://www.scottkuperus.com

    Same issue as joymccambridge and AUDIOMIND.

  28. dnoe
    Member
    Posted 2 years ago #

    Posting that information has done no good. In a different thread, facebook said the plugin is buggy... and to wait for a another release.

  29. nida78
    Member
    Posted 2 years ago #

    Like I posted in another thread the buggy places are not hard to find ;-)

  30. Matt Kelly (Facebook)
    Member
    Plugin Contributor

    Posted 2 years ago #

    Which version of WP are you folks running?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.