WordPress.org

Ready to get started?Download WordPress

Forums

How to Remove Leave a Reply (31 posts)

  1. synergyark
    Member
    Posted 2 years ago #

    I can't believe how hard this is!

    I've read a dozen posts with the same question and I couldn't figure out to make any of the offered solutions work.

    I am using Theme Twenty Ten 1.3 and I am building a website and not a blog, so I don't want a reply box at the bottom of every page.

    I don't have any checked boxes under Settings - Discussion.

    Many of the anwers I have found have recommended changing the php code.

    I would love to try that except I have no idea where to start looking for this code. I feel like I have been on every page of my WordPress site 3 dozen times.

    I just don't understand why there isn't a simple checkbox for removing the Leave a Reply box since WordPress is being used for websites as well as blogs now.

    Any suggestions will be greatly appreciated. I know there must be an answer I can understand somewhere!

  2. tribalNerd
    Member
    Posted 2 years ago #

    Hello synergyark,

    If you wish to remove the comments/replies stuff directly, here's the steps.

    1) Open your ftp to: /wp-content/themes/twentyten or whatever theme dir your theme may be within.

    2) Then open the loop-page.php, loop-single.php, and loop.php files. Search for the words 'comments_template'. Comment out those lines by adding // to the front of them.

    3) You can also try uploading a blank comments.php file... be sure to backup the org one first.

    That should do it though.

  3. synergyark
    Member
    Posted 2 years ago #

    THANK YOU VERY MUCH!

    It worked!

    For anybody else who needs to benefit from this post, let me tell you a couple of things that are probably obvious to anyone who has any idea about what they are doing.

    Yesterday was my first day with any form of website building at all, and I knew/know next to nothing.

    So the first thing is that if you want to get rid of the "Leave a Reply" box on WordPress, you don't remove it from the WordPress site. You did it from your ?host? site.

    I am using iPage as my host site.

    I tried going through the FTP page that iPage provides, but when I clicked on that icon I was directed to change my password. I tried that a few times but just got more confused and nowhere.

    Beside the FTP icon on iPage is "File Manager". Click on this.

    Open WP-Conten
    Open WP-Themes
    Open your theme - in my case it was Twenty Ten
    Then find the loop attachments as noted in the previous forum post.

    You'll find 'comments_template' right near the very bottom of all the text.

    Thanks again to TribalNerd for the advice.

    I went around in circles for about 4 hours yesterday. With TribalNerd's help, it took me less than 10 minutes.

    I still don't understand why WordPress doesn't have a checkbox for "Include Leave A Reply" on this page?

    How hard can that be????

  4. synergyark
    Member
    Posted 2 years ago #

    Okay, so I got rid of the Leave a Reply box, but now I have this:

    Pages
    Home
    Availability
    Budget
    Contact Us
    FAQ
    Photos
    Testimonials
    Blog
    Archives
    January 2012
    Categories
    Uncategorized (1)

    Blogroll
    Documentation
    Plugins
    Suggest Ideas
    Support Forum
    Themes
    WordPress Blog
    WordPress Planet
    Meta
    Log in
    Valid XHTML
    XFN
    WordPress

    Where did that come from? And how do I get rid of it?

    Any and all help is appreciated.

  5. tribalNerd
    Member
    Posted 2 years ago #

    Nice, glad that worked for you..

    That list looks like it's your sidebar?

    That would be under Appearance > Widgets

    If you have not setup any widgets, then the sidebar.php file is displaying that information by default. Add a few widgets to turn off the default display.

    The extra links, are probably coming from: Links > All Links

    Hope that helps....

  6. synergyark
    Member
    Posted 2 years ago #

    Thanks again.

    I added a calendar widget and as you predicted, all that text at the bottom of my page disappeared.

    I'll get WordPress figured out yet....

  7. astonfan
    Member
    Posted 2 years ago #

    Hi I am also trying to move the search, meta and archives bars on the right side of my pages but still no luck what is and where is the loop page as described above.....sorry new to this...Thanks

  8. synergyark
    Member
    Posted 2 years ago #

    I can't believe I am actually providing advice on something!

    All that should be required is for you to place a widget of your own in that right bar.

    If you don't want anything there at all, just go to "widgets", then choose the "text" option, and then leave the text box blank.

    Update your page and when you go to it, the right side should be blankity, blank, blank!

    Let me know if that works for you.

    Mike

  9. jere42
    Member
    Posted 2 years ago #

    Hi,
    I am on the 1.2 version of the same theme and I ran into that last week. I figured out that if I go into the pages from the dashboard, and hover each page it offers QuickEdit as one of the choices for a page. Select that and uncheck the Allow Comments checkbox. I think that may get the result you were looking for.

    Gerald

  10. astonfan
    Member
    Posted 2 years ago #

    Hi Mike/Gerald

    Thanks for your words of wisdom, i will give it a go and fingers crossed.

    Many Thanks

    David

  11. alastairclark
    Member
    Posted 2 years ago #

    HI Synergyark

    I am one month behind you - but suffering your same frustration. You instructions are helpful - but have not quite got me to conclusion.

    I have found the FTP files - I opened them in Note Pad and found the text requiring the slashes in front. I can not work out how to save this back! Stuck at last base! i am sure this is b++++++ obvious so would appreciate it if someone could point me to this.

  12. ohiageorge
    Member
    Posted 2 years ago #

    Wonderful!!! The trick worked for me.

    You are good man

  13. llavone77
    Member
    Posted 2 years ago #

    Ok I have made all the changes to the php file to remove comments, but my exiting posts still have a comment option. If I create a new post it is created with out the ability to leave a comment. What gives? Thanks for the help.

  14. llavone77
    Member
    Posted 2 years ago #

    Never mind the blank comments php file fixed everything!

  15. Nell265
    Member
    Posted 2 years ago #

    I was trying to find this out for the Twenty Eleven theme and came across the solution by accident. You don't need to amend code, at least not in this theme.

    - Go to the PAGE in question and select edit
    - At top right in edit mode there is a small box called 'screen options'
    - Checkmark the Discussion box
    - Scroll down to bottom of the page
    - Uncheck both 'Allow comments' and 'Allow trackbacks...'
    - Update the PAGE

    You will need to do this for each individual page.

  16. Mandos
    Member
    Posted 2 years ago #

    To Nell265

    THANK YOU THANK YOU THANK YOU! for the simple steps as highlighted above.

  17. vit77
    Member
    Posted 1 year ago #

    Thank you very much :D

  18. ahoyroo
    Member
    Posted 1 year ago #

    The blank comments.php file certainly helps to remove 'Leave a Reply' from the bottom of my non-blog pages (thanks for the tip).

    However, I still have an unwanted blog-related line of content on my non-blog static pages:
    'Posted on September 1, 2012 by [author name] — No Comments'

    I am currently using a theme called Responsive and this does not have any files called loop-page.php, loop-single.php, or loop.php - so I downloaded the entire directory (wp-content/themes/responsive) and searched the files for any instance of the phrase comments_template
    File list found:
    single.php
    sidebar-content-half-page.php
    sidebar-content-page.php
    full-width-page.php
    image.php
    page.php
    archive.php
    content-sidebar-half-page.php
    content-sidebar-page.php
    ...I have commented out (removed) the line of code near the bottom of all of these files containing the phrase comments_template but still my line of unwanted content about the author of the post (which isn't a post) remains.

    In the individual page's Screen Options (top right hand corner of Back Office for the page) none of the boxes are checked. Solution: commenting out the entire div for 'post-meta' from single.php and from full-width-page.php and then uploading those two files. The specific lines in the latter of these two files were numbered 37-58 when viewed in Notepad++.

    Hope this might help someone else (it's a closely related issue that I dealt with at the same time as sorting out how to remove 'Leave a Reply' box from my pages).

  19. phoebehaupt
    Member
    Posted 1 year ago #

    Hi All,

    I still could not figure out how to do what you all recommended - i.e. find the single loop php or even locate the File Manager.

    So, here is what I did and it worked ; ) This is for all of you out there who are clueless like me!

    1. Go to Dashboard

    2. Go to Appearance

    3. Select Editor

    4. On the right hand side it has a list under the word Templates.

    5. Select the one that says comments.

    6. I deleted the entire section, all text.

    7. Save changes.

    8. Done.

    I know this is totally amateur and probably not recommended but hey, I am an amateur ; )

  20. johns75
    Member
    Posted 1 year ago #

    Guys, why are you messing around with code? This is wordpress, its never that difficult, the hard stuff has already been done for you.

    Aron has already told you how to do this i a previous post. When you remove it in settings/discussions it only affects new post and pages. So you have to remove it from already published posts and pages by doing what Nell says:

    "I was trying to find this out for the Twenty Eleven theme and came across the solution by accident. You don't need to amend code, at least not in this theme.

    - Go to the PAGE in question and select edit
    - At top right in edit mode there is a small box called 'screen options'
    - Checkmark the Discussion box
    - Scroll down to bottom of the page
    - Uncheck both 'Allow comments' and 'Allow trackbacks...'
    - Update the PAGE

    You will need to do this for each individual page."

  21. fanggee
    Member
    Posted 1 year ago #

    Thank Nell265! it is as simple as a few click! no need to mess with the codes in FTP

  22. anewsong
    Member
    Posted 1 year ago #

    This has been the most frustrating thing ever! I have done what every one says. And no WORDPRESS isn't so easy you don't have to mess with code. I have nothing checked or marked in ADMIN SETTINGS or on individual posts to enable anyone to comment. The LEAVE A REPLY box is still there. So I did the // before the Comments Template and the REPLY did disappear. However, my entire right sidebar disappeared from the main page and my side widgets only appeared on post pages! Which means my twitter etc ended up not o he home page but on posts and pages. http://www.55plusmoney.com and I am using Magazine Basic by Bavota. he says we don't need to adjust code either and mentions the comments the Johns makes but they don't work. HELP!!! I want this to appear more like a website than a blog and that Leave A reply has to go. Thanks

  23. esmi
    Forum Moderator
    Posted 1 year ago #

    @anewsong: Please post your own topic.

  24. HIWD
    Member
    Posted 1 year ago #

    On WP 3.3.2 To remove the "Leave a Reply" open Pages = On the page you want to remove "leave a reply" click on "Quick Edit" and uncheck "Allow Comments" box

  25. mayankbpandya
    Member
    Posted 1 year ago #

    Sweet & Smart answer by HIWD, working very well thanks HIWD :)

  26. acorncommunity
    Member
    Posted 1 year ago #

    Hello

    I have done as mentioned in the above - Go to page - edit page - uncheck the discussion and comments boxes - update BUT Leave a reply is STILL there. I would try the ftp solution but I don't know where to find the ftp. please can someone tell me where this is. Any help appreciated.

  27. alchymyth
    Forum Moderator
    Posted 1 year ago #

    @acorncommunity

    please start your own topic - and post more details such as a link to your site.

  28. smarch1356
    Member
    Posted 1 year ago #

    I tried editing the single.php and edited out 'comments_template' line but no luck. However, when I just receated a new blank comments.php file that did the trick.
    Thanks for all the help on here, its a life saver!

  29. Sanjay Sethi
    Member
    Posted 1 year ago #

    THANK YOU Nell265! So simple and straight forward. Much appreciated!

  30. ACKLizard
    Member
    Posted 1 year ago #

    That worked wonderfully with the 2012 theme. Thanks!!

Topic Closed

This topic has been closed to new replies.

About this Topic