WordPress.org

Ready to get started?Download WordPress

Forums

How to link to blog from Static page (19 posts)

  1. EmmaApple
    Member
    Posted 5 years ago #

    I have a static home page (using the Revolution City free theme) and i'd like to have a link to the Blog (all the posts in blog format) is this possible?
    Thanks

  2. thisisedie
    Member
    Posted 5 years ago #

    What do you mean when you say you want a link to the blog? Because a link to the blog means <a href="theblogurl">The Name Of The Blog</a>

  3. EmmaApple
    Member
    Posted 5 years ago #

    I have a static front page, and i want to link to the posts in blog format, like how it would be if i didn't have a static front page.
    For example when i click a category link, it takes me to all the posts in that category in "blog format" and i want to link to all the posts in the blog like that.
    Tough to explain.

  4. EmmaApple
    Member
    Posted 5 years ago #

    Any help with this?

  5. vlgee
    Member
    Posted 5 years ago #

    If I understand correctly, you want people to see the blogs that have been written from your static page. you would have to edit the page with a snippet from the blog entry, maybe the title and the first few lines, then create a hyperlink to the actual blog entry. You could add text at the end of the snippet that says something like "read more" and then make a hyperlink to the actual post.

    Hope that helps

  6. EmmaApple
    Member
    Posted 5 years ago #

    Thanks vlgee. That's not what i meant though.

    Let me try to explain again:

    If i created a wordpress blog *without* a static front page, users visiting my blog would just see all the most recent posts one after another regardless of category right? (so all recent posts from all categories)

    Since i have a static front page, i have to link to the individual categories to see the most recent posts.

    What i'm asking about is a way to link to all the new posts regardless of category, so a link to a page much like how it would look if i did *not* have a static front page.

    Thanks

  7. thermodynamic
    Member
    Posted 5 years ago #

    I'd like a solution to this question as well. Basically is there any permalink to the blog portion of a WordPress blog itself?

    If you set it so that your name.wordpress.com displays a static page, then how can you also link to your blog?

  8. Coyotex
    Member
    Posted 5 years ago #

    I'm with you guys, I can't seem to figure this out either. Any help would be great! This is really starting to bug me!

  9. geezerd
    Member
    Posted 5 years ago #

    You had to give a name to your page that now has the blog (like "Blog"). That's the page you want to link to. Just make a hyperlink to it. Go to the blog page and copy the name in the address bar, and make your link: <a href="http://www.mywebsite/blog">See my latest posts</a>

  10. EmmaApple
    Member
    Posted 5 years ago #

    Thanks Geezerd, i'm still not getting it.

    Here's the link to the blog i'm trying to do this on http://www.outstandingeducators.com/ can you help me out here?
    If it helps, it's using the a Revolution theme and the homepage in the reading settings is NOT set to static, i guess that's not the way revolution works.
    Thanks

  11. Leo
    Member
    Posted 5 years ago #

    I think I understand what you are trying to do. Basically, you want the blog to be shown as normal, but just linked to through the navigation instead of being the main page, right?

    If that is the case and you are using WP 2.7 then it will be pretty simple. Create a new page and name it anything you want. I chose "blog" to keep it simple. Keep the content blank. Publish the page.

    Then, go to Settings > Reading. You should have already gone there to choose the static page. Keep the front page choice the same. For the posts page (i.e. your blog), choose the new page you just created (in my case, "blog"). That will give you the blog you desire in chronological format.

    Hopefully, I answered your question.

  12. brentchristian
    Member
    Posted 5 years ago #

    Yes, this is the answer to the original question.

    topic resolved

  13. EmmaApple
    Member
    Posted 5 years ago #

    Thanks Leo for your help, i'll see if i can get it to work following your instructions. I think i tried this before and it didn't work, but i will try again because i think it IS the answer.

    Also i'm using a home.php template file which means i don't set anything for the static homepage setting and it automatically just uses the customized home.php file i'm not sure if that's what's interfering but hopefully it will work with this try.

    Brent, if you don't mind, the topic is not resolved until i get it working.

  14. Mirz
    Member
    Posted 4 years ago #

    This is the way to do it, however there is one step in order to make it work. WordPress will not allow you to make an empty page. So, if you create a page, it will show up as draft. The way I got around this was by putting a non-breaking space on the page (&nbsp ; -- removing the space before the ;-sign). At that point, it worked perfectly.

  15. Lindsey Pahs
    Member
    Posted 4 years ago #

    To Leo,

    I had the same problem and your answer worked like a charm. Thanks so much!

    Lindsey Pahs
    http://www.mrpahs.com/

  16. jesset
    Member
    Posted 4 years ago #

    Hi,

    I'm having the exact same problem EmmaApple was having. My homepage is done through a home.php file, and so in Reading Settings, the home page is set to "Your Latest Posts." However, my home page shows "featured news", and I would like to have a separate static page that shows the posts in standard blog format.

    I created a static page called "Blog," filled b a non-breaking space. In reading settings, I set the Posts Page to "Blog," but the page remains empty.

    Any ideas? Thanks!

    --Jesse

  17. jesset
    Member
    Posted 4 years ago #

    Forgot to put my website, so maybe you can see the problem: http://www.brown.edu/Students/Brown_Democrats/

    Thank you!

  18. rhino18
    Member
    Posted 4 years ago #

    I have a similar issue to jesset's in wordpress 2.8.

    When I go to Settings > Reading I one page as the static front and another (a new, blank page, no special template selected) as the page that will publish all posts written.

    However, all this does is duplicate the front page on the news page. They are identical and use the home page's stylesheet and all.

  19. rhino18
    Member
    Posted 4 years ago #

    I renamed the static front page's template, it was home.php and not it is something else. Seems to be on its way to being fixed.

Topic Closed

This topic has been closed to new replies.

About this Topic